POJ 1035 Spell checker 【字符串暴力查找】

Spell checker


 
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
题意:给出一本字典,碰到#号结束
开始询问,每次一个单词,问你在字典中是否出现,若是出现则直接输出 temp is correct
如实没有直接出现,则问这个单词可以 通过哪些单词增加,删除,替换一个字母得到
思路:
唉呀妈呀,手残的不行了,敲代码的时候敲错了两处,直接导致我找了一个多小时错误都没找到,
脑子里想的是一回事,手上敲的是一回事,尴尬
题目本身并没有什么难度,只要注意细节就行了
对于找得到的不多说,另一部分找不到的,只有三种情况下才可以从字典中的单词做修改得到
一种是长度一样,需要替换一个单词的(操作,跳过),再有就是长度长1,需要增加一个字母的(操作,直接忽略当前不一样的字母,继续向下,如果可以的到,一定是可以走到头的),还有就是需要删除一个字母的(操作,跳过字典中的读出来的,理由同上)
记录下字典,直接暴力即可
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<string>
using namespace std;
#define ll long long
#define mod 1000000007
#define N 10010
int n;
int length[N];
char map[N][50];
char temp[50];
int len;
int judgestring(string a,string b)
{
    if(a.size()!=b.size())
        return 0;
    for(int i=1;i<a.size();i++)
    {
        if(a[i]!=b[i])
            return 0;
    }
    return 1;
}
int judge(int a)
{
    int i,t;
    t=length[a]-len;
    if(t==-1)
    {
        for(i=0;i<length[a];)
        {
            if(map[a][i]!=temp[i])
                break;
            else i++;
        }
        for(;i<length[a];)
        {
            if(map[a][i]!=temp[i+1])
                break;
                else i++;
        }

        if(i==length[a])
            return 0;
    }
    else if(t==0)
    {
        for(i=0;i<len;)
        {
            if(map[a][i]!=temp[i])
                break;
                else i++;
        }
        i++;
        for(;i<len;)
        {
            if(map[a][i]!=temp[i])
                break;
            else i++;
        }
        if(i==len)
            return 0;
    }
    else if(t==1)
        {
            for(i=0;i<len;)
            {
                if(map[a][i]!=temp[i])
                    break;
                    else i++;
            }
            for(;i<len;)
            {
                if(map[a][i+1]!=temp[i])
                break;
                else i++;
            }
            if(i==len)
                return 0;
        }
    return 1;
}
int main()
{
    /*string a,b;
    while(cin>>a>>b)
        cout<<judgestring(a,b)<<endl;*/
    for(int i=0;;i++)
    {
        scanf("%s",&map[i][0]);
        length[i]=strlen(map[i]);
        if(map[i][0]=='#')
        {
                n=i;
                break;
        }
    }
    for(int j=1;;j++)
    {
        int flag=-1;
        scanf("%s",temp);
        if(temp[0]=='#')
            break;
        len=strlen(temp);
        for(int i=0;i<n;i++)
        {
            if(length[i]==len&&strcmp(map[i],temp)==0)
            {
                cout<<temp<<" is correct"<<endl;
                flag=1;
                break;
            }
        }
        if(flag==-1)
        {
            cout<<temp<<":";
            for(int i=0;i<n;i++)
                if(judge(i)==0)
                    cout<<" "<<map[i];
                cout<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值