Cat Snuke and a Voyage AtCoder - 2660

Problem Statement

 

In Takahashi Kingdom, there is an archipelago of N islands, called Takahashi Islands. For convenience, we will call them Island 1, Island 2, ..., Island N.

There are M kinds of regular boat services between these islands. Each service connects two islands. The i-th service connects Island ai and Island bi.

Cat Snuke is on Island 1 now, and wants to go to Island N. However, it turned out that there is no boat service from Island 1 to Island N, so he wants to know whether it is possible to go to Island N by using two boat services.

Help him.

Constraints

 

  • 3≤N≤200 000
  • 1≤M≤200 000
  • 1≤ai<biN
  • (ai,bi)≠(1,N)
  • If ij(ai,bi)≠(aj,bj).

Input

 

Input is given from Standard Input in the following format:

N M
a1 b1
a2 b2
:
aM bM

Output

 

If it is possible to go to Island N by using two boat services, print POSSIBLE; otherwise, print IMPOSSIBLE.

Sample Input 1

 

3 2
1 2
2 3

Sample Output 1

 

POSSIBLE

Sample Input 2

 

4 3
1 2
2 3
3 4

Sample Output 2

 

IMPOSSIBLE

You have to use three boat services to get to Island 4.

Sample Input 3

 

100000 1
1 99999

Sample Output 3

 

IMPOSSIBLE

Sample Input 4

 

5 5
1 3
4 5
2 3
2 4
1 4

Sample Output 4

 

POSSIBLE

You can get to Island 5 by using two boat services: Island 1 -> Island 4 -> Island 5.

关于划船问题,从1道n只能转一次船也必须转一次船,所以需要有【1,c】,【c,n】两条船,所以只需要保存a=1的值和b=n的值。

上代码:

#include<iostream>
#include<cmath>
#include <algorithm>
using namespace std;
int main()
{
	int arr[200000];
	int brr[200000];
	int n,m;
	cin>>n>>m;
	int p=0,q=0;
	for(int i=0;i<m;i++)
	{
		int a,b;
		cin>>a>>b;
		if(a==1)
		{
			arr[p++]=b;
		}
		if(b==n)
		{
			brr[q++]=a;
		}
	}
	if(p==0||q==0)
	{
		cout<<"IMPOSSIBLE";
	}
	else
	{
		sort(arr,arr+p);
		sort(brr,brr+q);
		int i,j=1;
		for(i=0;i<p;i++)
		{
			j--;
			for(j;j<q;j++)
			{
				if(arr[i]==brr[j])
				{
					break;
				}
				if(arr[i]<brr[j])
					break;
			}
			if(arr[i]==brr[j])
			break;
		}
		if(arr[i]==brr[j]&&i!=p)
			cout<<"POSSIBLE";
		else
			cout<<"IMPOSSIBLE";
	}
 } 

  

 

转载于:https://www.cnblogs.com/mozheaishang/p/10017334.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过信息化手段提升教育、管理和服务水平,实现资源数字化、工作流程化、管理高效化和决策智能化。方案包括智慧校园信息化平台和安防平台的建设,涉及教学、科研、管理和服务等多个方面,以满足现代教育和培训需求。 技术服务要求强调了统一支撑平台的建设,包括数据标准、接口标准、代码标准和用户信息标准的统一制定。平台需满足信创和X86交叉适配要求,确保安全自主可控的系统开发环境。此外,方案还涵盖了用户中心系统、统一认证授权中心、统一工作流中心、统一智能报表中心等多个模块,以及数据共享中心、语音识别、移动服务终端等功能,以实现校园内外部信息的互联互通和资源共享。 智慧校园信息化平台的建设还包括了对教学管理、人事管理、公文管理、档案管理、即时通讯、会议管理、督办工作、资产管理等方面的数字化和自动化升级。这些模块的集成旨在提高工作效率,优化资源配置,加强监督管理,并通过移动应用等技术手段,实现随时随地的信息访问和业务处理。 安防平台的建设则侧重于校园安全,包括停车场管理、人脸识别测温、访客自助登记、视频监控等多个系统。这些系统的集成旨在提高校园的安全管理水平,实现对校园内外人员和车辆的有效监控和管理,确保校园环境的安全稳定。 最后,方案还提到了对固定资产的管理,包括购置、使用、归还、报废等全生命周期的管理,以及对网络设备、安防设备、服务器等硬件设施的配置和管理。通过这些措施,智慧校园建设方案旨在为校园提供一个安全、高效、便捷的学习和工作环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值