2009 Multi-University Training Contest 1 - Host by TJU B.( Cube Stacking ) 带权并查集

链接:

HDU: http://acm.hdu.edu.cn/showproblem.php?pid=2818

POJ:  http://poj.org/problem?id=1988

 

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 17412 Accepted: 6007
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

 
 
  虽然看出是和并查集密切相关, 但开始尝试每次合并时更新, TLE. 
  看别人代码, 每次查询父节点时更新, 即每次把连在把连在父节点上的子节点连到祖宗上去时, 更新rank的值. 相当于压缩路径同时更新节点值. 又因为是递归地查询, 所以在更新子节点的rank值之前, 父亲节点也作为子节点做了同样的事(把父节点和连着的一嘟噜子节点连到祖宗节点上, 同时更新自己的rank值), 保证了并查集树高度不超过3. 
 
 
#include <iostream>
using namespace std;

#define rep(i, n) for (int i = 0, _n = (int)(n); i < _n; i++)
////
const int N = 30009;
int num[N],rk[N],f[N];//  rk : rank
int x,y,n,p;
char c;

int fd(int x){
    if(x==f[x]) return x;
    int fa = f[x];
    f[x] = fd(f[x]);
    rk[x] += rk[fa];
    return f[x];
}

void unin(int x,int y){
    int a = fd(x), b = fd(y);
    if(a==b) return;
    f[a] = b;
    rk[a]=num[b];
    num[b]+=num[a];
    num[a] = 0;
}


int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&p);
    rep(i,N) num[i]=1,f[i]=i,rk[i]=0;
    while(p--){
        scanf("\n%c%d",&c,&x);
        if(c=='M'){
            scanf("%d",&y);
            unin(x,y);
        }
        else{
            fd(x);
            printf("%d\n", rk[x]);
        }
    }
    return 0;
}

 

 

 

 

 

完全参考: http://blog.csdn.net/shuangde800/article/details/8007224

转载于:https://www.cnblogs.com/rewrite/p/3592640.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值