UVa OJ 641 - Do the Untwist (解密工作)

Time limit: 3.000 seconds

 

Background

Cryptography deals with methods of secret communication that transform a message (the plaintext) into a disguised form (the ciphertext) so that no one seeing the ciphertext will be able to figure out the plaintext except the intended recipient. Transforming the plaintext to the ciphertext is encryption; transforming the ciphertext to the plaintext is decryption. Twisting is a simple encryption method that requires that the sender and recipient both agree on a secret key k, which is a positive integer.


The twisting method uses four arrays: plaintext and ciphertext are arrays of characters, and plaincode and ciphercode are arrays of integers. All arrays are of length n, where n is the length of the message to be encrypted. Arrays are origin zero, so the elements are numbered from 0 to n - 1. For this problem all messages will contain only lowercase letters, the period, and the underscore (representing a space).


The message to be encrypted is stored in plaintext. Given a key k, the encryption method works as follows. First convert the letters in plaintext to integer codes in plaincode according to the following rule: 'SPMamp_&' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26, and '.' = 27. Next, convert each code in plaincode to an encrypted code in ciphercode according to the following formula: for all i from 0 to n - 1,


ciphercode[i] = (plaincode[ki mod n] - i) mod 28.

(Here x mod y is the positive remainder when x is divided by y. For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. You can use the C '%' operator or Pascal 'mod' operator to compute this as long as you add y if the result is negative.)

Finally, convert the codes in ciphercode back to letters in ciphertext according to the rule listed above. The final twisted message is in ciphertext. Twisting the message "cat" using the key 5 yields the following:

 

Array012
plaintext'c''a''t'
plaincode3120
ciphercode31927
ciphertext'c''s''.'

 

Your task is to write a program that can untwist messages, i.e., convert the ciphertext back to the original plaintext given the key k. For example, given the key 5 and ciphertext 'cs.', your program must output the plaintext 'cat'.

 

Input

The input file contains one or more test cases, followed by a line containing only the number 0 that signals the end of the file. Each test case is on a line by itself and consists of the key k, a space, and then a twisted message containing at least one and at most 70 characters. The key k will be a positive integer not greater than 300.

 

Output

For each test case, output the untwisted message on a line by itself.

Note: you can assume that untwisting a message always yields a unique result. (For those of you with some knowledge of basic number theory or abstract algebra, this will be the case provided that the greatest common divisor of the key k and length n is 1, which it will be for all test cases.)

 

Sample Input

5 cs.
101 thqqxw.lui.qswer
3 b_ylxmhzjsys.virpbkr
0

 

Sample Output

cat
this_is_a_secret
beware._dogs_barking

 

Analysis

直接反转公式即可。由于原公式中取模操作的特殊性,平码可直接由密码取28的模得到。

 

Solution

#include <iostream>
#include <string>
#include <vector>
using namespace std;
int main(void) {
	int i, k, nCipherCode;
	char szCipherText[71];
	char szPlainText[71];
	vector<string> vecPlainTexts;
	while (cin >> k) {
		if ( k == 0 ) {
			break;
		}
		cin >> szCipherText;
		int nLen = strlen(szCipherText);
		for (i = 0; szCipherText[i] != 0; ++i) {
			if (szCipherText[i] == '_') nCipherCode = 0;
			else if (szCipherText[i] == '.') nCipherCode = 27;
			else nCipherCode = szCipherText[i] - 'a' + 1;
			int nPlainCode = (nCipherCode + i) % 28;
			if (nPlainCode == 0) szPlainText[(k * i) % nLen] = '_';
			else if (nPlainCode == 27) szPlainText[(k * i) % nLen] =  '.';
			else szPlainText[(k * i) % nLen] = nPlainCode + 'a' - 1;
		}
		szPlainText[i] = 0;
		vecPlainTexts.push_back(szPlainText);
	}
	for (vector<string>::iterator iter = vecPlainTexts.begin();
		iter != vecPlainTexts.end(); ++iter) {
			cout << *iter << endl;
	}
	return 0;
}

转载于:https://www.cnblogs.com/devymex/archive/2010/08/04/1792486.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值