斯特林公式

斯特林公式用于求n阶乘的近似值。

n!的位数:lg(n!)=lg1+lg2+...+lgn向下取整+1;

例题:

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41322    Accepted Submission(s): 20219


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
  
21020
 

Sample Output
 
  
719
 

Source
 

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int n,t;
double ans;

int main()
{
	cin >> t;
	while(t--)
	{
		scanf("%d",&n);
		ans=0.0;
		for(int i=1;i<=n;i++)
			ans+=log10(i);
		printf("%d\n",(int)ans+1);  
	}
	return 0;  
}

转载于:https://www.cnblogs.com/Radium1209/p/10415382.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值