【7-10 PAT】树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 

 

#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;

const int maxn = 2e5 + 5;

struct Node
{
    int val,l,r;
}node[maxn];
int tot = 0;
int zhong[maxn],hou[maxn];

int dfs(int len,int zhong[],int hou[])
{
    if(len <= 0)
        return -1;
    if(len == 1)
    {
        node[++tot].val = hou[1];
        node[tot].l = node[tot].r = -1;
//        printf("len == 1 %d\n",tot);
        return tot;

    }
    node[++tot].val = hou[len];
//    printf("%d %d\n",tot,node[tot].val);
    int res = tot;
    int l;
    for(l = 1;l <= len;l++)
        if(zhong[l] == hou[len])
            break;
    node[res].l = dfs(l-1,zhong,hou);
    node[res].r = dfs(len - l,zhong + l,hou + l - 1);
    return res;
}

void bfs()
{
    queue<int>que;
    que.push(1);
    while(!que.empty())
    {
        int cur = que.front();
        que.pop();
        if(cur != 1)
            printf(" ");
        printf("%d",node[cur].val);
        if(node[cur].l != -1)
            que.push(node[cur].l);
        if(node[cur].r != -1)
            que.push(node[cur].r);
    }
}


int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&hou[i]);
    for(int i=1;i<=n;i++)
        scanf("%d",&zhong[i]);
    dfs(n,zhong,hou);
    bfs();
    return 0;
}

 

转载于:https://www.cnblogs.com/smallhester/p/10620204.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值