HDU 5089 Assignment(rmq+二分 或 单调队列)

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 557    Accepted Submission(s): 280


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test。output the number of groups.
 

Sample Input
 
   
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
 
   
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5299  5298  5297  5296  5295 



rmq+二分

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;
const int mod=1e9+7;

using namespace std;

#define N 100007

int a[N],n;
int dpmin[N][25],dpmax[N][25];
int k;

inline bool judge(int le,int ri)
{
    int kk=log2((ri-le+1)*1.0);
    int mi=min(dpmin[le][kk],dpmin[ri-(1<<kk)+1][kk]);
    int ma=max(dpmax[le][kk],dpmax[ri-(1<<kk)+1][kk]);
    return ma-mi<k;
}

int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=n;i++)
            dpmin[i][0]=dpmax[i][0]=a[i];

        for(j=1;(1<<j)<=n;j++)
            for(i=1;i+(1<<j)-1<=n;i++)
            {
                int p=1<<(j-1);
                dpmin[i][j]=min(dpmin[i][j-1],dpmin[i+p][j-1]);
                dpmax[i][j]=max(dpmax[i][j-1],dpmax[i+p][j-1]);
            }

         __int64 ans=0;
         int le,ri,p;
         for(i=1;i<=n;i++)
         {
             le=i;
             ri=n;
             while(le<=ri)
             {
                 int mid=(le+ri)>>1;
                 if(judge(i,mid))
                 {
                     p=mid;
                     le=mid+1;
                 }
                 else
                    ri=mid-1;
             }
             ans+=p-i+1;
         }
         printf("%I64d\n",ans);
    }
    return 0;
}


单调队列
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8

using namespace std;
const int mod=1e9+7;

#define INF 0x3f3f3f3f

const int N=100005;

int mique[N],maque[N],mihead,mahead,mitail,matail;
int n,a[N],k;

int pre,now;
__int64 ans;

inline void miinque(int i)
{
    while(mihead<mitail&&a[i]<a[mique[mitail-1]]) mitail--;
    mique[mitail++]=i;
}

inline void mainque(int i)
{
    while(mahead<matail&&a[i]>a[maque[matail-1]]) matail--;
      maque[matail++]=i;
}

void outque(int pos)
{
    if(a[maque[mahead]]-a[mique[mihead]]>=k)
    {
        int nowlen=pos-now-1;
        int prelen=pre-now;
        ans+=(__int64)(nowlen+1)*nowlen/2;
        if(prelen>=1)
            ans-=(__int64)(prelen+1)*prelen/2;
        pre=pos-1;
    }
    while(a[maque[mahead]]-a[mique[mihead]]>=k)
        if(mique[mihead]<maque[mahead])
        {
            now=mique[mihead]+1;
            mihead++;
        }
        else
        {
            now=maque[mahead]+1;
            mahead++;
        }
}

int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        mihead=mahead=mitail=matail=0;
        pre=now=1;
        ans=0;
        for(i=1;i<=n;i++)
        {
            miinque(i);
            mainque(i);
            outque(i);
        }
        if(pre<n)
        {
           int nowlen=n-now;
           int prelen=pre-now;
           ans+=(__int64)(nowlen+1)*(nowlen)/2;
           if(prelen>=1)
            ans-=(__int64)(prelen+1)*(prelen)/2;
           pre=n-1;
        }

        printf("%I64d\n",ans+n);
    }
    return 0;
}



转载于:https://www.cnblogs.com/cxchanpin/p/6875204.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值