hdu 4451 Dressing 衣服裤子鞋 简单容斥

Dressing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3735    Accepted Submission(s): 1681

Problem Description
Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing. One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs. Please calculate the number of different combinations of dressing under mom’s restriction.
 

 

Input
There are multiple test cases. For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes. Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious. Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”. The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K). Input ends with “0 0 0”. It is guaranteed that all the pairs are different.
 

 

Output
For each case, output the answer in one line.
 

 

Sample Input
2 2 2 0 2 2 2 1 clothes 1 pants 1 2 2 2 2 clothes 1 pants 1 pants 1 shoes 1 0 0 0
 

 

Sample Output
8 6 5
 

 

Source
题意:给你N件衣服M条裤子K双鞋子,其中一些衣服跟裤子不能组合在一起或者是裤子跟鞋子不能组合在一起,在这种情况下,求出合理的组合套数。
 
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
#include <set>
using namespace std;
typedef long long ll;
typedef unsigned long long Ull;
#define MM(a,b) memset(a,b,sizeof(a));
const double eps = 1e-10;
const int  inf =0x7f7f7f7f;
const double pi=acos(-1);
const int maxn=40000;

char s1[20],s2[20];
int x,y,f1[1005],f2[1005];
int main()
{
    int n,m,k,p;
    while(~scanf("%d %d %d",&n,&m,&k)&&(n||m||k))
    {
        scanf("%d",&p);
        MM(f1,0);MM(f2,0);
        int cnt1=0,cnt2=0;
        for(int i=1;i<=p;i++)
        {
            scanf("%s %d %s %d",s1,&x,s2,&y);
            if(s1[0]=='c') {cnt1++;f1[y]++;}
            else {cnt2++;f2[x]++;}
        }
        int res=cnt1*k+n*cnt2;
        for(int i=1;i<=m;i++)
            res-=f1[i]*f2[i];
        printf("%d\n",n*m*k-res);
    }
    return 0;
}

分析:比较基础的一道容斥,题目是求合法的搭配,那么我们转化为求不合法的搭配,首先统计
单个的一对衣服和鞋或鞋和裤子的搭配,可以容易求出其对应的不合理的搭配数之和,但是

中间可能会有重复算了的,因为可能一种搭配中衣服-裤子与裤子-鞋都不符合,那么需要再减去

这种重复的,只要统计下一种裤子同时被衣服和鞋共用的次数就好

转载于:https://www.cnblogs.com/smilesundream/p/5656790.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值