【HDU4451】Dressing 容斥

Problem Description

Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.

Input

There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.

Output

For each case, output the answer in one line.

Sample Input

2 2 2
0
2 2 2
1
clothes 1 pants 1
2 2 2
2
clothes 1 pants 1
pants 1 shoes 1
0 0 0

Sample Output

8
6
5

题目大意

顺次给出衣服,裤子,鞋子的数量,再给出哪两种衣服和裤子或者裤子和鞋子不能够搭配,输出有多少种穿衣服的方案

题解

方法一:考虑容斥原理,先算出总共的,减去不能搭配的最后再加上多减去的
方法二:记录对于一个裤子不能搭配的鞋子和衣服的数量,最后遍历一遍乘起来求和

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
const int MAXN=1e5;
const int maxn=1e2;
char s1[maxn],s2[maxn];
int pos1,pos2,n,m,k,sum,num1[MAXN],num2[MAXN],Num;
using namespace std;
int main()
{
    while(scanf("%d%d%d",&n,&m,&k)&&n&&m&&k)
    {
        scanf("%d",&Num);
        while(Num--)
        {
            scanf("%s%d%s%d",&s1,&pos1,&s2,&pos2);
            if(s1[0]=='c'&&s2[0]=='p')
            {
                num1[pos2]++;
            }
            if(s1[0]=='p'&&s2[0]=='s')
            {
                num2[pos1]++;
            }
        }
        for(int i=1;i<=m;i++) sum+=(n-num1[i])*(k-num2[i]);
        printf("%d\n",sum);
        memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num2));
        sum=0;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值