CDOJ 383 Japan 树状数组

                                                    Japan

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (1M100001N10000). K superhighways will be build.(1K1000000) Cities on each coast are numbered 1,2, from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – NMK. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: Test case (case number): (number of crossings)

Sample input and output

Sample Input
1
3 4 4
1 4
2 3
3 2
3 1
Sample Output
Test case 1: 5

题解:树状数组求逆序对
///1085422276
#include<bits/stdc++.h>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a));
#define TS printf("111111\n");
#define FOR(i,a,b) for( int i=a;i<=b;i++)
#define FORJ(i,a,b) for(int i=a;i>=b;i--)
#define READ(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define inf 100000
inline ll read()
{
    ll x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}
//****************************************
#define maxn 1000000+10
int c[maxn],n,m,k;
struct ss
{
    int x,y;
}a[maxn];
bool cmp(ss s1,ss s2)
{
    if(s1.x==s2.x)
      return s1.y<s2.y;
    return s1.x<s2.x;
}
int lowbit(int x){return x&(-x);}
int getsum(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
void update(int x,int v)
{
    while(x<=m)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{

    int T=read();
    int oo=1;
    while(T--)
    {
        mem(c);
         n=read(),m=read(),k=read();
         int x,y;
        FOR(i,1,k)
        {
            scanf("%d%d",&x,&y);
            a[i].x=x;
            a[i].y=y;
        }
        ll ans=0;
        sort(a+1,a+k+1,cmp);
         //  for(int i=1;i<=k;i++)cout<<a[i].x<<" "<<a[i].y<<endl;
        for(int i=1;i<=k;i++)
        {
            update(a[i].y,1);
            ans+=i-getsum(a[i].y);
          //  cout<<ans<<endl;
        }
        printf("Test case %d: ",oo++);
        cout<<ans<<endl;
    }
    return 0;
}

 





转载于:https://www.cnblogs.com/zxhl/p/4868130.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值