ZOJ 2475 Benny's Compiler(dfs判断有向图给定点有没有参与构成环)

B - Benny's Compiler
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

These days Benny has designed a new compiler for C programming language. His compilation system provides a compiler driver that invokes the language preprocessor, compiler, assembler and linker. C source file (with .C suffix) is translated to relocatable object module first, and then all modules are linked together to generate an executable object file.

The translator (preprocessor, compiler and assembler) works perfectly and can generate well optimized assembler code from C source file. But the linker has a serious bug -- it cannot resolve global symbols when there are circular references. To be more specific, if file 1 references variables defined in file 2, file 2 references variables defined in file 3, ... file n-1 references variables defined in file n and file n references variables defined in file 1, then Benny's linker walks out because it doesn't know which file should be processed first.

Your job is to determine whether a source file can be compiled successfully by Benny's compiler.

 

Input

 

There are multiple test cases! In each test case, the first line contains one integer N, and then N lines follow. In each of these lines there are two integers Ai and Bi, meaning that file Ai references variables defined in file Bi (1 <= i <= N). The last line of the case contains one integer E, which is the file we want to compile.

A negative N denotes the end of input. Else you can assume 0 < N, Ai, Bi, E <= 100.

 

Output

 

There is just one line of output for each test case. If file E can be compiled successfully output "Yes", else output "No".

 

Sample Input

 

4
1 2
2 3
3 1
3 4
1

4
1 2
2 3
3 1
3 4
4

-1

 

Sample Output

 

No
Yes

题目意思:
有向图 叫你判断给定点有没有参与构成环
分析:
因为是有向图
所以并查集不能解决
直接dfs搜一波
 
code:
#include<stdio.h>
#include<iostream>
#include<vector>
#include <cstring>
#include <stack>
#include <cstdio>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include<string>
#include<string.h>
#include<math.h>
typedef long long LL;
using namespace std;
#define max_v 105
int vis[max_v];
int G[max_v][max_v];
int flag;
void dfs(int k)
{
    for(int i=1;i<max_v;i++)
    {
        if(vis[i]==1&&G[k][i]==1)
        {
            flag=0;
            return ;
        }
        if(G[k][i]==1)
        {
            vis[i]=1;
            dfs(i);
            vis[i]=0;
        }
    }
}
int main()
{
    int n;
    int x,y;
    while(~scanf("%d",&n))
    {
        if(n<0)
            break;
        memset(vis,0,sizeof(vis));
        memset(G,0,sizeof(G));

        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&x,&y);
            if(x!=y)
                G[x][y]=1;
        }
        int k;
        scanf("%d",&k);

        vis[k]=1;
        flag=1;

        dfs(k);

        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
}
/*
题目意思:
有向图 叫你判断给定点有没有参与构成环

分析:
因为是有向图
所以并查集不能解决
直接dfs搜一波
*/

 

 

转载于:https://www.cnblogs.com/yinbiao/p/9494609.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值