[HUST 1017] Exact cover

Exact cover

Time Limit: 15s Memory Limit: 128MB

Special Judge Submissions: 6012 Solved: 3185
DESCRIPTION
There is an N*M matrix with only 0s and 1s, (1 <= N,M <= 1000). An exact cover is a selection of rows such that every column has a 1 in exactly one of the selected rows. Try to find out the selected rows.
INPUT
There are multiply test cases. First line: two integers N, M; The following N lines: Every line first comes an integer C(1 <= C <= 100), represents the number of 1s in this row, then comes C integers: the index of the columns whose value is 1 in this row.
OUTPUT
First output the number of rows in the selection, then output the index of the selected rows. If there are multiply selections, you should just output any of them. If there are no selection, just output "NO".
SAMPLE INPUT
6 7
3 1 4 7
2 1 4
3 4 5 7
3 3 5 6
4 2 3 6 7
2 2 7
SAMPLE OUTPUT
3 2 4 6
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define MaxNode 100010
#define MaxN 1010
#define MaxM 1010

struct DLX
{
    int n,m,size;
    int U[MaxNode],D[MaxNode],R[MaxNode],L[MaxNode];
    int Row[MaxNode],Col[MaxNode];
    int H[MaxN],S[MaxM];
    int ansd, ans[MaxN];

    void Init(int _n,int _m)
    {
        n=_n;
        m=_m;
        for(int i=0;i<=m;i++)
        {
            S[i]=0;
            U[i]=D[i]=i;
            L[i]=i-1;
            R[i]=i+1;
        }
        R[m]=0;L[0]=m;
        size=m;
        for(int i=1;i<=n;i++)
            H[i]=-1;
    }
    void Link(int r,int c)
    {
        ++S[Col[++size]=c];
        Row[size]=r;
        U[size]=U[c];
        D[U[c]]=size;
        D[size]=c;
        U[c]=size;
        if(H[r]==-1) H[r]=L[size]=R[size]=size;
        else
        {
            L[size]=L[H[r]];
            R[L[H[r]]]=size;
            R[size]=H[r];
            L[H[r]]=size;
        }
    }
    void Remove(int c)
    {
        L[R[c]]=L[c];
        R[L[c]]=R[c];
        for(int i=D[c];i!=c;i=D[i])
        {
            for(int j=R[i];j!=i;j=R[j])
            {
                U[D[j]]=U[j];
                D[U[j]]=D[j];
                S[Col[j]]--;
            }
        }
    }
    void Resume(int c)
    {
        for(int i = U[c];i != c;i = U[i])
        {
            for(int j = L[i];j != i;j = L[j])
            {
                U[D[j]]=j;
                D[U[j]]=j;
                S[Col[j]]++;
            }
        }
        L[R[c]] =c;
        R[L[c]] =c;
    }
    bool Dance(int d)
    {
        if(R[0]==0)
        {
            ansd=d;
            return 1;
        }
        int c=R[0];
        for(int i=R[0];i!=0;i=R[i])
            if(S[i]<S[c]) c=i;
        Remove(c);
        for(int i=D[c];i!=c;i=D[i])
        {
            ans[d]=Row[i];
            for(int j=R[i];j!=i;j=R[j]) Remove(Col[j]);  //移除
            if(Dance(d+1)) return 1;
            for(int j=L[i];j!=i;j=L[j]) Resume(Col[j]);  //回标
        }
        Resume(c);
        return 0;
    }
}g;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        g.Init(n,m);
        for(int i=1;i<=n;i++)
        {
            int num,j;
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d",&j);
                g.Link(i,j);
            }
        }
        if(!g.Dance(0)) printf("NO\n");
        else
        {
            printf("%d",g.ansd);
            for(int i=0;i<g.ansd;i++)
                printf(" %d",g.ans[i]);
            printf("\n");
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/hate13/p/4183395.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值