hust1017-Exact cover 舞蹈链之精确覆盖(裸的)

There is an N*M matrix with only 0s and 1s, (1 <= N,M <= 1000). An exact cover is a selection of rows such that every column has a 1 in exactly one of the selected rows. Try to find out the selected rows.
Input
There are multiply test cases. First line: two integers N, M; The following N lines: Every line first comes an integer C(1 <= C <= 100), represents the number of 1s in this row, then comes C integers: the index of the columns whose value is 1 in this row.
Output
First output the number of rows in the selection, then output the index of the selected rows. If there are multiply selections, you should just output any of them. If there are no selection, just output "NO".
Sample Input
6 7
3 1 4 7
2 1 4
3 4 5 7
3 3 5 6
4 2 3 6 7
2 2 7
Sample Output

3 2 4 6


题意:很裸,n行m列,然后给出每行中1的个数和位置,然后问精确覆盖需要几行,并要求打出行数和行号


思路:矩阵已经构造好直接套精确覆盖模板即可是不是非常裸呢^@^


ac代码:

#include <vector>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int inf=0x3f3f3f3f;
const ll INF=0x3f3f3f3f3f3f3f3fll;
const int maxn=1010;
int L[maxn*100],R[maxn*100],U[maxn*100],D[maxn*100];//节点的上下左右四个方向的链表
int C[maxn*100],H[maxn],cnt[maxn],vis[maxn],ans[maxn],Row[maxn*100];//C列H行cnt列链表中元素个数
int n,m,id,len;
void init(){
    for(int i=0;i<=m;i++){
        cnt[i]=0;U[i]=D[i]=i;
        L[i+1]=i;R[i]=i+1;
    }
    R[m]=0;id=m+1;
    memset(H,-1,sizeof(H));
}
void Link(int r,int c){
    cnt[c]++;C[id]=c;Row[id]=r;
    U[id]=U[c];D[U[c]]=id;
    D[id]=c;U[c]=id;Row[id]=r;
    if(H[r]==-1) H[r]=L[id]=R[id]=id;
    else{
        L[id]=L[H[r]];R[L[H[r]]]=id;
        R[id]=H[r];L[H[r]]=id;
    }
    id++;
}
void Remove(int Size){
    L[R[Size]]=L[Size];
    R[L[Size]]=R[Size];
    for(int i=D[Size];i!=Size;i=D[i]){
        for(int j=R[i];j!=i;j=R[j]){
            U[D[j]]=U[j];D[U[j]]=D[j];
            cnt[C[j]]--;
        }
    }
}
void Resume(int Size){
    for(int i=D[Size];i!=Size;i=D[i]){
        for(int j=R[i];j!=i;j=R[j]){
            U[D[j]]=j;D[U[j]]=j;
            cnt[C[j]]++;
        }
    }
    L[R[Size]]=Size;R[L[Size]]=Size;
}
int Dance(int k){
    int pos,mm=maxn;
    if(R[0]==0){
        len=k;
        return 1;
    }
    for(int i=R[0];i;i=R[i]){
        if(mm>cnt[i]){
            mm=cnt[i];pos=i;
        }
    }
    Remove(pos);
    for(int i=D[pos];i!=pos;i=D[i]){
        ans[k]=Row[i];
        for(int j=R[i];j!=i;j=R[j]) Remove(C[j]);
        if(Dance(k+1)) return 1;
        for(int j=L[i];j!=i;j=L[j]) Resume(C[j]);
    }
    Resume(pos);
    return 0;
}
int main(){
    int u,v,a;
    while(scanf("%d%d",&n,&m)!=-1){
        init();
        for(int i=1;i<=n;i++){
            scanf("%d",&a);
            while(a--){
                scanf("%d",&u);
                Link(i,u);
            }
        }
        int flag=Dance(0);
        if(flag==0) printf("NO\n");
        else{
            printf("%d",len);
            for(int i=0;i<len;i++) printf(" %d",ans[i]);
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值