HDU 1162Eddy's picture(MST问题)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11841    Accepted Submission(s): 5922

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.
Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

 
 

3 1.0 1.0 2.0 2.0 2.0 4.0

Sample Output

 
 

3.41

Author

eddy

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1217 1875 1879 1863 1325

分析:

最小生成树问题(采用克鲁斯卡尔算法)

不过边还需要自己求(两点间的距离公式,点的组合)

code:

#include<bits/stdc++.h>
using namespace std;
#define max_v 105
struct edge
{
    int x,y;
    double w;
};
edge e[max_v*max_v];
int pa[max_v],rk[max_v];
double sum=0.0;
bool cmp(edge a,edge b)
{
    return a.w<b.w;
}
void make_set(int x)
{
    pa[x]=x;
    rk[x]=0;
}
int find_set(int x)
{
    if(x!=pa[x])
        pa[x]=find_set(pa[x]);
    return pa[x];
}
void union_set(int x,int y,double w)
{
    x=find_set(x);
    y=find_set(y);
    if(x==y)
        return ;
    if(rk[x]>rk[y])
        pa[y]=x;
    else
    {
        if(rk[x]==rk[y])
            rk[y]++;
        pa[x]=y;
    }
    sum+=w;
    return ;
}
double f(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        sum=0;
        double a[max_v],b[max_v];
        for(int i=0; i<n; i++)
        {
            make_set(i);
            scanf("%lf %lf",&a[i],&b[i]);
        }
        int k=0;
        for(int i=0; i<n; i++)
        {
            for(int j=i+1; j<n; j++)
            {
                e[k].x=i;
                e[k].y=j;
                e[k++].w=f(a[i],b[i],a[j],b[j]);
            }
        }
        sort(e,e+k,cmp);
        for(int i=0; i<k; i++)
        {
            union_set(e[i].x,e[i].y,e[i].w);
        }
        printf("%0.2lf\n",sum);
    }
    return 0;
}

转载于:https://www.cnblogs.com/yinbiao/p/9250659.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值