POJ3420Quad Tiling(矩阵快速幂)

Quad Tiling

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3740 Accepted: 1684
Description

Tired of the Tri Tiling game finally, Michael turns to a more challengeable game, Quad Tiling:

In how many ways can you tile a 4 × N (1 ≤ N ≤ 109) rectangle with 2 × 1 dominoes? For the answer would be very big, output the answer modulo M (0 < M ≤ 105).

Input

Input consists of several test cases followed by a line containing double 0. Each test case consists of two integers, N and M, respectively.

Output

For each test case, output the answer modules M.

Sample Input

1 10000
3 10000
5 10000
0 0
Sample Output

1
11
95
Source

POJ Monthly–2007.10.06, Dagger

递推式:a[i]=a[i-1]+5*a[i-2]+a[i-3]-a[i-4];

由于N高达10^9,所以要用矩阵进行优化。
|0 1 0 0|
|0 0 1 0|
|0 0 0 1|
|-1 1 5 1|

|a[i-3]|
|a[i-2]|
|a[i-1]|
|a[i]|
相乘

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <cstdlib>
#include <algorithm>
#define LL long long

using namespace std;
const int  Max = 10;

int Mod;
struct Matrix
{
    int n,m;
    int a[Max][Max];
    void clear()//清空矩阵
    {
        n=0;
        m=0;
        memset(a,0,sizeof(a));
    }
    Matrix operator * (const Matrix &b)const//矩阵相乘
    {
        Matrix tmp;
        tmp.clear();
        tmp.n=n;
        tmp.m=b.m;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<b.m;j++)
            {
                for(int k=0;k<m;k++)
                {
                    tmp.a[i][j]=(tmp.a[i][j]+(a[i][k]%Mod)*(b.a[k][j]%Mod))%Mod;
                }
            }
        }
        return tmp;
    }
};



void Pow(int m)
{
    Matrix s;
    s.clear();
    s.n=4;
    s.m=4;
    s.a[3][3]=1;s.a[3][2]=5;
    s.a[3][1]=1;s.a[3][0]=-1;
    s.a[1][2]=1;s.a[2][3]=1;
    s.a[0][1]=1;

    Matrix ans;
    ans.clear();
    ans.n=4;
    ans.m=1;
    ans.a[0][0]=1;
    ans.a[1][0]=5;
    ans.a[2][0]=11;
    ans.a[3][0]=36;
    while(m)//快速幂
    {
        if(m&1)
        {
            ans=s*ans;
        }
        s=s*s;
        m>>=1;
    }
    printf("%d\n",ans.a[3][0]);
}

int main()
{ 
    int n;
    while(scanf("%d %d",&n,&Mod),n)
    {
        if(n<4)
        {
            switch(n)
            {
                case 1:
                    printf("%d\n",1%Mod);
                    break;
                case 2:
                    printf("%d\n",5%Mod);
                    break;
                case 3:
                    printf("%d\n",11%Mod);
                    break;
            }
            continue;
        }
        Pow(n-4);
    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255898.html

以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值