sgu 142. Keyword 暴力,hash 难度:0

142. Keyword

time limit per test: 0.5 sec. 
memory limit per test: 16384 KB

 

Kevin has invented a new algorithm to crypt and decrypt messages, which he thinks is unbeatable. The algorithm uses a very large key-string, out of which a keyword is found out after applying the algorithm. Then, based on this keyword, the message is easily crypted or decrypted. So, if one would try to decrypt some messages crypted with this algorithm, then knowing the keyword would be enough. Someone has found out how the keyword is computed from the large key-string, but because he is not a very experienced computer programmer, he needs your help. The key-string consists of N characters from the set {'a','b'}. The keyword is the shortest non-empty string made up of the letters 'a' and 'b', which is not contained as a contiguous substring (also called subsequence) inside the key-string. It is possible that more than one such string exists, but the algorithm is designed in such a way that any of these strings can be used as a keyword. Given the key-string, your task is to find one keyword.

 

Input

The first line contains the integer number N, the number of characters inside the key-string (1 <= N <= 500 000). The next line contains N characters from the set {'a','b'} representing the string.

 

Output

The first line of output should contain the number of characters of the keyword. The second line should contain the keyword.

 

Sample Input

11
aabaaabbbab

Sample Output

4
aaaa

因为长度不会超过log(n),直接暴力计算

#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int n;
char str[500005];
bool use[1000005];
int llen[20];
int limit;
bool insrt(int st,int len){
   int key=0;
    for(int i=st;i<st+len;i++){
        key<<=1;
        if(str[i]=='b')key+=1;
    }
    if(use[key])return false;
    else return use[key]=true;
}
char ans[21];
int main(){
    scanf("%d%s",&n,str);
    while((1<<limit)<=n)limit++;
    for(int i=1;i<=limit;i++){
        for(int j=0;j<=n-i;j++){
            if(insrt(j,i))llen[i]++;
        }
        if(llen[i]<(1<<i)){
            printf("%d\n",i);
            for(int j=(1<<i)-1;j>=0;j--){
                if(!use[j]){
                    int base=1;
                    for(int k=0;k<i;k++){
                        ans[i-1-k]='a'+((j&(base))?1:0);
                        base<<=1;
                    }
                    break;
                }
            }
            break;
        }
        memset(use,0,(1<<i));
    }
    printf("%s\n",ans);
    return 0;
}

  

转载于:https://www.cnblogs.com/xuesu/p/4047194.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值