HUD:3746-Cyclic Nacklace(补齐循环节)

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.
这里写图片描述
As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5


解题心得:

  1. 题目说了一大堆,其实就是问你要在这个字符串的后面添加多少个字符才能够让字符中的每一个循环节都完整。
  2. 先找出循环节,然后检查需要补多少个字符让每一个循环节都完整,如果没有循环节,那么就直接在这个字符串后面添加一个相同的字符串。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<string>
using namespace std;
const int maxn = 1e5+100;
char s[maxn];
int Next[maxn];

int cal_next(){
    int k = -1;
    Next[0] = -1;
    int len = strlen(s);
    for(int i=1;i<len;i++) {
        while (k > -1 && s[i] != s[k + 1])
            k = Next[k];
        if (s[i] == s[k + 1])
            k++;
        Next[i] = k;
    }
    int cir = len-1-Next[len-1];//循环节的长度
    if(Next[len-1] == -1)//如果整个个字符串都没循环节就直接添加一个相同的字符串
        return len;
    if(len%cir == 0)//已经是完整的循环节
        return 0;
    return cir-len%cir;//需要补齐的字符个数
}

int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        scanf("%s",s);
        int ans = cal_next();
        printf("%d\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/GoldenFingers/p/9107185.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值