POJ 2080 Calendar

题目链接:

http://poj.org/problem?id=2080

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. 
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years. 
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

 Hint:

题意:

给出一个n,表示天数,让你求出以2000年1月1日 星期六为起点,n天后的具体的时间。

题解:

其实思路蛮简单的,就是慢慢推过去,而且n的范围也不是很大,不用担心会超时的问题,就是输出时的格式需要注意下,自己就被坑了2次 。

代码:

#include <cmath>
#include <cstdio>
#include <cstring> 
#include <algorithm> 
using namespace std;
char weekend[][20]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int days_of_year(int year)
{
    if((year%4==0&&year%100!=0)||year%400==0)
        return 366;
    else
        return 365;
}
int days_of_month(int month,int year)
{
    int ans=0;
    if(month==2)
        return days_of_year(year)==366?29:28;
    switch(month)
    {
        case 1:case 3:case 5:case 7:case 8:case 10:case 12:
            ans=31;
            break;
        default:
            ans=30;
    }
    return ans;
}
int  main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        int week=n%7;
        int year=2000;
        int month=1;
        int  day=1;
        while(n)
        {
            if(n>=days_of_year(year))
            {
                n-=days_of_year(year);
                ++year;
            }
            else if(n>=days_of_month(month,year))
            {
                n-=days_of_month(month,year);
                ++month;
            }
            else
            {
                day+=n;
                n=0;
            }
        }
        printf("%d-%02d-%02d %s\n",year,month,day,weekend[week]);
    }
}

 

转载于:https://www.cnblogs.com/TAT1122/p/5830071.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值