HDU-4920 Matrix multiplication

            矩阵相乘,采用一行的去访问,比采用一列访问时间更短,根据数组是一行去储存的。神奇小代码。         

             Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1476    Accepted Submission(s): 650


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
 

 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

 

Sample Input
1
0
1
2
0 1
2 3
4 5
6 7
 
 

 

Sample Output
0
0 1
2 1
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[805][805],b[805][805],c[805][805];
int main()
{
    int k,i,n,j,x;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                scanf("%d",&x);
                a[i][j]=x%3;
            }
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                scanf("%d",&x);
                b[i][j]=x%3;
            }
        for(k=1; k<=n; k++)
        {
            for(j=1;j<=n; j++)
            {
                for(i=1;i<=n; i++)
                {
                    c[k][i]+=a[k][j]*b[j][i];
                }
            }
        }
        for(i=1;i<=n; i++)
        {
            for(j=1;j<n; j++)
                printf("%d ",c[i][j]%3);
            printf("%d\n",c[i][n]%3);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/cancangood/p/3894747.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值