HDU 4911 Inversion(基本算法-排序,基本算法-分治)

Inversion



Problem Description
bobo has a sequence a 1,a 2,…,a n. He is allowed to swap two  adjacent numbers for no more than k times.

Find the minimum number of inversions after his swaps.

Note: The number of inversions is the number of pair (i,j) where 1≤i<j≤n and a i>a j.
 

Input
The input consists of several tests. For each tests:

The first line contains 2 integers n,k (1≤n≤10 5,0≤k≤10 9). The second line contains n integers a 1,a 2,…,a n (0≤a i≤10 9).
 

Output
For each tests:

A single integer denotes the minimum number of inversions.
 

Sample Input
 
  
3 1 2 2 1 3 0 2 2 1
 

Sample Output
 
  
1 2
 

Author
Xiaoxu Guo (ftiasch)
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4930  4929  4928  4927  4926 
 

题目大意:

有n个数,问你经过K次交换后的逆序数最少多少个?


解题思路:

根据排序的思想,每一步都能减少1个逆序数,所以K步之多减少K个逆序数。

因此,这题转化为了求逆序数,数据量略微大,用归并排序即可。


解题代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=110000;
int n,m,d[maxn];
typedef long long ll;

ll query(int l,int r){
    if(l>=r) return 0;
    else if(l+1==r){
        if(d[r]>=d[l]) return 0;
        else return 1;
    }
    else{
        int mid=(l+r)/2;
        ll ret=query(l,mid)+query(mid+1,r);
        sort(d+l,d+mid+1);
        for(int i=mid+1;i<=r;i++){
            ret+=(int)( (d+mid+1) - upper_bound(d+l,d+mid+1,d[i]) );
        }
        return ret;
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<n;i++) scanf("%d",&d[i]);
        ll ans=query(0,n-1);
        if(ans<=m) printf("0\n");
        else cout<<ans-m<<endl;
    }
    return 0;
}


版权声明:欢迎关注我的博客,本文为博主toyking原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/toyking/p/4951008.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值