pta 习题集 数列求和-加强版

给定某数字AA1≤A≤91A9)以及非负整数NN0≤N≤1000000N100000),求数列之和S=A+AA+AAA+⋯+AA⋯AS=A+AA+AAA++AAANNAA)。例如A=1A=1N=3N=3时,S=1+11+111=123S=1+11+111=123

输入格式:

输入数字AA与非负整数NN

输出格式:

输出其NN项数列之和SS的值。

输入样例:

1 3

输出样例:

123
大数
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <string>
#include <map>

using namespace std;
typedef long long int LL;
LL a,n;
LL cnt;
LL b[200005];
int main()
{
	scanf("%lld%lld",&a,&n);
	cnt=200000;
	LL cot=cnt;
	LL x=0;
	for(LL i=n;i>=1;i--)
	{
		b[cnt]=(a*i+x)%10;
		
		x=(a*i+x)/10;
		cnt--;
	}
	int tag=1;
	if(x!=0)
	{
		printf("%lld",x);
		tag=0;
	}
	
	for(LL i=cnt+1;i<=cot;i++)
	{
		
			printf("%lld",b[i]);
		tag=0;
	}
	if(tag)
		printf("0");
	printf("\n");
	return 0;
}


转载于:https://www.cnblogs.com/dacc123/p/8228554.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值