HDU-1050Moving Tables

本文针对HDU ACM竞赛中MovingTables问题进行了解析,该问题是关于如何最高效地在一个长走廊两侧的房间间移动桌子的问题。文章提供了一种通过计数每个走廊区域被使用次数的方法来解决此问题,并给出了具体的实现代码。
摘要由CSDN通过智能技术生成

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=1050

 

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

 

Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
 

 

Sample Output
10
20
30

 总结

今天做了三道题,这是第三道。我只想说这个HDU的文档有点毒瘤,明明说的贪心,结果却不是用它做的,一开始自己的想法有问题了,想要将区间左边排序,来求公共区间,结果发现自己做不来。看了网上的思路,是将区间分成数组,重复一次就自增一,就能求了。

#include<iostream>
#include<cstdio>
#include<memory.h>
using namespace std;

int count1[205];


int main()
{
    int T,n,t,beg,end;
    cin >>T;
    while(T--){
        cin >>n;
        memset(count1,0,sizeof(count1));
        for(int i=0;i<n;i++){
            scanf("%d %d",&beg,&end);
            if(beg>end) {t=beg;beg=end;end=t;}
            for(int j=(beg+1)/2;j<=(end+1)/2;j++)
                count1[j]++;
        }
        int max=0;
        for(int i=0;i<201;i++)
            if(count1[i]>max) max=count1[i];
        cout <<max*10<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangdongkai/p/5272982.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值