POJ3436 ACM Computer Factory

POJ3436 ACM Computer Factory
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3345Accepted: 1112Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, whereQi specifies performance, Si,j — input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.
***************************************************************************************
题目大意:有p个零件和n个机器。每个机器加工时对这p个零件是否存在有一定的要求。现在给出每台机器的加工效率,加工时对p的要求,加工完后p的状况。求使得p全为1的最快的组合。
解题思路:拆点+最大流。
#include <stdio.h>
#include <string.h>
#include <vector>
#define N 205
#define P 15
#define M 1000005
#define INF 0x3f3f3f3f
#define tk(a,b) (a+b*n)
using namespace std;

int in[N][P],ou[N][P],pe[N];
int p,n,source,sink,eid,nn;
int head[N],ed[M],nxt[M],val[M],vis[M],sta[M];
int dist[N],gap[N];
vector<int>ansa,ansb,ansc;

void add_edge(int s,int e,int v,int xv)
{
    sta[eid]=s;         if(!v)vis[eid]=1;
    ed[eid]=e;          val[eid]=v;
    nxt[eid]=head[s];   head[s]=eid++;
    sta[eid]=e;         if(!xv)vis[eid]=1;
    ed[eid]=s;          val[eid]=xv;
    nxt[eid]=head[e];   head[e]=eid++;
}

int ISAP(int pos,int cost)
{
    if(pos==sink)
        return cost;
    int lv=cost,minh=nn-1;
    for(int i=head[pos];~i;i=nxt[i])
    {
        int e=ed[i],v=val[i];
        if(v>0)
        {
            if(dist[pos]==dist[e]+1)
            {
                int d=min(v,lv);
                d=ISAP(e,d);
                lv-=d;
                val[i]-=d;
                val[i^1]+=d;
                if(dist[source]>=nn)return cost-lv;
                if(lv==0)break;
            }
            minh=min(minh,dist[e]);
        }

    }
    if(lv==cost)
    {
        gap[dist[pos]]--;
        if(!gap[dist[pos]])dist[source]=nn;
        dist[pos]=minh+1;
        gap[dist[pos]]++;
    }
    return cost-lv;
}

void re(void)
{
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&pe[i]);
        for(int j=1;j<=p;j++)
            scanf("%d",&in[i][j]);
        for(int j=1;j<=p;j++)
            scanf("%d",&ou[i][j]);
    }
}

void run(void)
{
    source=0;
    sink=2*n+1;
    eid=0;
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        add_edge(tk(i,0),tk(i,1),pe[i],0);
    for(int i=1;i<=n;i++)
    {
        int mark1=0,mark2=0;
        for(int j=1;j<=p;j++)
            if(in[i][j]==1)
            {
                mark1=1;
                break;
            }
        if(!mark1)
            add_edge(source,tk(i,0),INF,0);
        for(int j=1;j<=p;j++)
            if(ou[i][j]==0)
            {
                mark2=1;
                break;
            }
        if(!mark2)
            add_edge(tk(i,1),sink,INF,0);
        if(!mark1)
            continue;
        for(int j=1;j<=n;j++)
        {
            if(i==j)continue;
            mark1=0;
            for(int k=1;k<=p;k++)
                if((in[i][k]==0&&ou[j][k]==1)||(in[i][k]==1&&ou[j][k]==0))
                {
                    mark1=1;
                    break;
                }
            if(mark1)continue;
            add_edge(tk(j,1),tk(i,0),INF,0);
        }
    }
    nn=2*n+2;
    memset(dist,0,sizeof(dist));
    memset(gap,0,sizeof(gap));
    int ans=0;
    while(dist[source]<nn)
        ans+=ISAP(source,INF);
    printf("%d ",ans);
    ansa.clear();
    ansb.clear();
    ansc.clear();
    for(int i=0;i<eid;i++)
    {
        if(vis[i]==0||val[i]==0)continue;
        int s=ed[i],e=sta[i],v=val[i];
        if(s==source||e==sink)continue;
        if(s>n)s-=n;
        if(e>n)e-=n;
        if(s==e)continue;
        ansa.push_back(s);
        ansb.push_back(e);
        ansc.push_back(v);
    }
    printf("%d\n",ansa.size());
    for(int i=0;i<ansa.size();i++)
        printf("%d %d %d\n",ansa[i],ansb[i],ansc[i]);
}

int main()
{
    while(scanf("%d%d",&p,&n)==2)
    {
        re();
        run();
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/Fatedayt/archive/2011/10/19/2217566.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值