POJ3436解题思路

ACM Computer Factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6344 Accepted: 2219 Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part j, Di,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ N ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.


关键点在如何建图:这道题考察的是最大流问题,但两点之间的流的大小不是由边决定而是由机器的性能决定,所以这里要把每台电脑拆分成两个点,建好图后直接跑EK,EK函数里不要用队列存储点,要用栈!

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<stack>
#define inf 999999
using namespace std;
struct node
{
    int pow;
    int input[110];
    int output[110];
} a[110];
struct mapp
{
    int data;
    int vis;
} map[110][110];
int flow[110][110];
int pre[110];
int n;
int bfs(int s,int t)
{
    int bb[110];
    int f,i,j;
    f=0;
    stack<int>q;
    memset(flow,0,sizeof(flow));
    while(1)
    {
        memset(bb,0,sizeof(bb));
        bb[s]=inf;
        q.push(s);
        while(!q.empty())
        {
            int u=q.top();
            q.pop();
            for(i=0; i<=t; i++)
            {
                if(!bb[i]&&map[u][i].vis==1&&map[u][i].data>flow[u][i])
                {
                    pre[i]=u;
                    bb[i]=min(bb[u],map[u][i].data-flow[u][i]);
                    q.push(i);
                }
            }
        }
        if(bb[t]==0) break;
        for(i=t; i!=s; i=pre[i])
        {
            flow[pre[i]][i]+=bb[t];
            flow[i][pre[i]]-=bb[t];
        }
        f+=bb[t];
    }
    cout<<f<<" ";
    int num=0;
    for(i=1; i<=t-1; i++)
    {
        for(j=1; j<=t-1; j++)
        {
            if(flow[i][j]>0&&i%2==0)
            {
                num++;
            }
        }
    }
    cout<<num<<endl;
    for(i=1; i<=t-1; i++)
    {
        for(j=1; j<t; j++)
        {
            if(flow[i][j]>0)
            {
                if(i%2==0)
                cout<<i/2<<" "<<(j+1)/2<<" "<<flow[i][j]<<endl;
            }
        }
    }
    return 0;
}
int main()
{
    int p,i,j,k;
    while(cin>>p>>n)
    {
        for(i=0; i<=2*n+1; i++)
        {
            for(j=0; j<=2*n+1; j++)
            {
                map[i][j].data=inf;
                map[i][j].vis=0;
            }
        }
        for(i=1; i<=n; i++)
        {
            cin>>a[i].pow;
            for(j=1; j<=p; j++)
            {
                cin>>a[i].input[j];
            }
            for(j=1; j<=p; j++)
            {
                cin>>a[i].output[j];
            }
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=p; j++)
            {
                if(a[i].input[j]==1)
                {
                   break;
                }
            }
            if(j==p+1)
            {
                map[0][2*i-1].data=inf;
                map[0][2*i-1].vis=1;
            }
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=p; j++)
            {
                if(a[i].output[j]!=1)
                    break;
            }
            if(j==p+1)
            {
                map[2*i][2*n+1].data=inf;
                map[2*i][2*n+1].vis=1;
            }
        }
        for(i=1; i<=n; i++)
        {
            if(map[0][2*i-1].vis==1)
                map[0][2*i-1].data=a[i].pow;
        }
        for(i=1; i<=n; i++)
        {
            if(map[2*i][2*n+1].vis==1)
                map[2*i][2*n+1].data=a[i].pow;
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i==j) continue;
                for(k=1; k<=p; k++)
                {
                    if(a[i].output[k]!=a[j].input[k])
                    {
                        if(a[j].input[k]!=2) break;
                    }
                }
                if(k==p+1)
                {
                    map[2*i][2*j-1].data=min(a[i].pow,a[j].pow);
                    map[2*i][2*j-1].vis=1;
                }
            }
        }
        for(i=1;i<=n;i++)
        {
            map[2*i-1][2*i].data=a[i].pow;
            map[2*i-1][2*i].vis=1;
        }
        bfs(0,2*n+1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值