HDU2444(判断是否为二分图,求最大匹配)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3836    Accepted Submission(s): 1797

Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
 
Sample Output
No
3
 
Source
 
题意:给定n个点m条边的无向图,判断是否为二分图,如果不是输出No,是则输出最大匹配。
判断是否为二分图:dfs,如果某个点u没有赋id,则赋为1,找到所有与他相邻的点,如果存在某个点id和该点相同则return false; 如果id==0则赋为-1*id[u]继续dfs;
求最大匹配用匈牙利算法,注意由于原图是个无向图,是自己人工把他当成二分图,所以如果左边的点1和右边的点2之间有边,则右边的点1和左边的点2之间也有边,所有求出的最大匹配要除以2;
/*
ID: LinKArftc
PROG: 2444.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 510;
const int maxm = 250010;

int mp[maxn][maxn];
int linker[maxn];
int id[maxn];
int uN, vN;
int n, m;
bool vis[maxn];

bool dfs(int x) {
    for (int i = 1; i <= n; i ++) {
        if (mp[x][i]) {
            if (id[i] == id[x]) return false;
            if (id[i] == 0) {
                id[i] = -1 * id[x];
                if (!dfs(i)) return false;
            }
        }
    }
    return true;
}

bool dfs1(int u) {
    for (int v = 1; v <= n; v ++) {
        if (mp[u][v] && !vis[v]) {
            vis[v] = true;
            if (linker[v] == -1 || dfs1(linker[v])) {//刚开始这地方写成dfs了,罪过呀,写的有点混乱,下次注意!
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungry() {
    memset(linker, -1, sizeof(linker));
    int ret = 0;
    for (int i = 1; i <= n; i ++) {
        memset(vis, 0, sizeof(vis));
        if (dfs1(i)) ret ++;
    }
    return ret;
}

int main() {
    //input;
    int u, v;
    while (~scanf("%d %d", &n, &m)) {
        memset(mp, 0, sizeof(mp));
        memset(id, 0, sizeof(id));
        for (int i = 1; i <= m; i ++) {
            scanf("%d %d", &u, &v);
            mp[u][v] = 1;
            mp[v][u] = 1;
        }
        bool flag = true;
        for (int i = 1; i <= n; i ++) {
            if (!id[i]) {
                id[i] = 1;
                if (!dfs(i)) {
                    flag = false;
                    break;
                }
            }
        }
        if (!flag) {
            printf("No\n");
            continue;
        } else printf("%d\n", hungry() / 2);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/LinKArftc/p/4908307.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了模 n 意义下的所有原根,我们需要先出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于最大公约数,phi 函数用于欧拉函数,pow 函数用于快速幂模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值