HDU4310:Hero

Problem Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.
There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.
To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.
Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 
Output
Output one line for each test, indicates the minimum HP loss.
 
Sample Input
1 10 2 2 100 1 1 100
 
Sample Output
20 201
 
//英语是硬伤。。。要不是看了别人的题解,我真心不知道原来输入时浮点型呀!!!
//这道题直接给我弄迷糊了。。。
//血量少攻击高的要先消灭,即将所有的敌人根据DPS/HP从大到小排序,如果相等,则按HP从小到大排序。
 
#include <iostream>
#include <algorithm>

using namespace std;

struct node
{
    double hp;
    double dps;
    double bi;
} data[25];

bool cmp(const node &a,const node &b)
{
   if(a.bi>b.bi)
   return true;
   else if(a.bi==b.bi)
   {
       if(a.dps<b.dps)
       return true;
       else return false;
   }
   else return false;
}

int main()
{
    int n;
    double ans;
    while(cin>>n)
    {
        ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>data[i].hp>>data[i].dps;
            data[i].bi=data[i].dps/data[i].hp*1.0;
        }
        sort(data,data+n,cmp);
        for(int i=0;i<n;i++)
        {
            while(data[i].hp)
            {
                for(int j=i;j<n;j++)
                ans+=data[j].dps;
                data[i].hp--;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/nefu929831238/p/5350134.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值