HDU 4310 Hero (贪心算法)

A - Hero
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 4310

Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN. 

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS. 

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds. 

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output

Output one line for each test, indicates the minimum HP loss.
 

Sample Input

1 10 2 2 100 1 1 100
 

Sample Output

20 201
题意:Dota游戏中有n组敌人,每次攻击一个敌人会使这个敌人的HP减1,但是同时你的英雄
   的DPS(开始是是无穷的)的值会减少,减少值为所有在当前回合仍存活的敌人的DPS
   总和,若敌人的HP<=0会在这一回合结束后死亡。要求将所有的敌人都消灭后你的英雄
   的DPS剩余的最多,即求耗费的DPS的值最少。

分析:用贪心解决。血量少攻击高的要先消灭,所以以HP/DPS作为参数排序,即将所有的敌人

   根据DPS/HP从大到小排序,如果相等,则按HP从小到大排序。记得要把测试样例删了,

   忘了删测试样例WA了一次之后一血没了- -。

#include <iostream>
#include <string.h>
#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct sa
{
    int hp,dps;
    double c;
}data[105];
bool cmp(sa x,sa y)
{
    return x.c>y.c;
}
int main()
{
    int i,n,t,sum,ans;
    while(cin>>n)
    {
        sum=0;ans=0;
        memset(data,0,sizeof(data));
        for(i=0;i<n;i++)
        {
            cin>>data[i].dps>>data[i].hp;
            data[i].c=double(data[i].dps)/double(data[i].hp);
            sum+=data[i].dps;
        }
        sort(data,data+n,cmp);
        for(i=0;i<n;i++)
        {
            ans+=data[i].hp*sum;
            sum-=data[i].dps;
            //cout<<ans<<endl;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Ritchie/p/5432371.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值