历届试题 小计算器
时间限制:1.0s 内存限制:256.0MB
问题描述
模拟程序型计算器,依次输入指令,可能包含的指令有
1. 数字:‘NUM X’,X为一个只包含大写字母和数字的字符串,表示一个当前进制的数
2. 运算指令:‘ADD’,‘SUB’,‘MUL’,‘DIV’,‘MOD’,分别表示加减乘,除法取商,除法取余
3. 进制转换指令:‘CHANGE K’,将当前进制转换为K进制(2≤K≤36)
4. 输出指令:‘EQUAL’,以当前进制输出结果
5. 重置指令:‘CLEAR’,清除当前数字
指令按照以下规则给出:
数字,运算指令不会连续给出,进制转换指令,输出指令,重置指令有可能连续给出
运算指令后出现的第一个数字,表示参与运算的数字。且在该运算指令和该数字中间不会出现运算指令和输出指令
重置指令后出现的第一个数字,表示基础值。且在重置指令和第一个数字中间不会出现运算指令和输出指令
进制转换指令可能出现在任何地方
运算过程中中间变量均为非负整数,且小于2^63。
以大写的’A’'Z’表示1035
输入格式
第1行:1个n,表示指令数量
第2…n+1行:每行给出一条指令。指令序列一定以’CLEAR’作为开始,并且满足指令规则
输出格式
依次给出每一次’EQUAL’得到的结果
样例输入
7
CLEAR
NUM 1024
CHANGE 2
ADD
NUM 100000
CHANGE 8
EQUAL
样例输出
2040
解析:直接用java大数做,java大数还有转换进制的功能,所以这里就能更加方便些
具体看代码吧
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BigInteger x;
BigInteger k;
int n;
String str;
str = br.readLine();
int now = 0;
for (int i = 0; i < str.length(); i++) {
now = now * 10 + (int) (str.charAt(i) - '0');
}
n = now;
BigInteger now1 = BigInteger.valueOf(0);
int nowk = 10;
int pp = -1;
while (n-- != 0) {
str = br.readLine();
if (str.substring(0, 3).compareTo("CLE") == 0) {
pp = 5;
} else if (str.substring(0, 3).compareTo("ADD") == 0) {
pp = 0;
} else if (str.substring(0, 3).compareTo("SUB") == 0) {
pp = 1;
} else if (str.substring(0, 3).compareTo("MUL") == 0) {
pp = 2;
} else if (str.substring(0, 3).compareTo("DIV") == 0) {
pp = 3;
} else if (str.substring(0, 3).compareTo("MOD") == 0) {
pp = 4;
} else if (str.substring(0, 3).compareTo("NUM") == 0) {
BigInteger now2 = BigInteger.valueOf(0);
for (int i = 4; i < str.length(); i++) {
if (str.charAt(i) >= '0' && str.charAt(i) <= '9') {
now2 = (now2.multiply(BigInteger.valueOf(nowk)))
.add(BigInteger.valueOf((int) (str.charAt(i) - '0')));
} else
now2 = now2.multiply(BigInteger.valueOf(nowk))
.add(BigInteger.valueOf((int) (str.charAt(i) - 'A'+10)));
}
if (pp == 5) {
now1 = now2;
} else if (pp == 0) {
now1 = now1.add(now2);
} else if (pp == 1) {
now1 = now1.subtract(now2);
} else if (pp == 2) {
now1 = now1.multiply(now2);
} else if (pp == 3) {
now1 = now1.divide(now2);
} else if (pp == 4) {
now1 = now1.mod(now2);
}
} else if (str.substring(0, 3).compareTo("CHA") == 0) {
int now2 = 0;
for (int i = 0; i < str.length(); i++) {
if (str.charAt(i) >= '0' && str.charAt(i) <= '9') {
now2 = now2 * 10 + (int) (str.charAt(i) - '0');
}
}
nowk = now2;
} else if (str.substring(0, 3).compareTo("EQU") == 0) {
int cnt = 0;
String str1 = new BigInteger(now1.toString()).toString(nowk);
for(int i=0;i
if(str1.charAt(i)>='a'&&str1.charAt(i)<='z') {
System.out.print((char)(str1.charAt(i)-'a'+'A'));
}
else {
System.out.print(str1.charAt(i));
}
}
System.out.println();
}
}
}
}