poj 3268 Silver Cow Party(最短路dijkstra)

描述:

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
 

题解:

  要求的其实就是1-n的每个点到x以及从x回来的最短路之和的最大值。就可以用两次dijkstra算法求解,一次算从i到x,一次算从x到i,最后求得相加的最大值即可。

代码:

#include <iostream>
#include <stdio.h>

using namespace std;
#define inf 1<<29
int n,m,x;
bool vis[1010];
int map[1010][1010];
int go[1010],dback[1010];  //go是从i—>x  back是从x—>i

int dijkstra()
{
    int i,j,f,v;
    for(i=1;i<=n;i++)
    {
        vis[i]=0;
        go[i]=map[i][x];
        dback[i]=map[x][i];
    }

    for(i=1;i<=n;i++)
    {
        f=inf;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&dback[j]<f)
            {
                v=j;
                f=dback[j];
            }
        }
        vis[v]=1;
        for(j=1;j<=n;j++)
            if(!vis[j]&&map[v][j]+dback[v]<dback[j])
                dback[j]=map[v][j]+dback[v];
    }

    for(i=1;i<=n;i++) vis[i]=0;

    for(i=1;i<=n;i++)
    {
        f=inf;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&go[j]<f)
            {
                v=j;
                f=go[j];
            }
        }
        vis[v]=1;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&map[j][v]+go[v]<go[j])
                go[j]=map[j][v]+go[v];
        }
    }

    f=-1;
    for(i=1;i<=n;i++)
    {
        if(go[i]+dback[i]>f)
            f=go[i]+dback[i];
    }
    return f;
}

int main()
{
    int a,b,c;
    while(~scanf("%d%d%d",&n,&m,&x)){
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                if(i!=j) map[i][j]=inf;
                else map[i][j]=0;
            }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=c;
        }
        printf("%d\n",dijkstra());
    }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/y1040511302/p/10466583.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值