Rock, Scissors, Paper
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 3106 | Accepted: 1838 |
Description
Bart's sister Lisa has created a new civilization on a two-dimensional grid. At the outset each grid location may be occupied by one of three life forms: Rocks, Scissors, or Papers. Each day, differing life forms occupying horizontally or vertically adjacent grid locations wage war. In each war, Rocks always defeat Scissors, Scissors always defeat Papers, and Papers always defeat Rocks. At the end of the day, the victor expands its territory to include the loser's grid position. The loser vacates the position.
Your job is to determine the territory occupied by each life form after n days.
Your job is to determine the territory occupied by each life form after n days.
Input
The first line of input contains t, the number of test cases. Each test case begins with three integers not greater than 100: r and c, the number of rows and columns in the grid, and n. The grid is represented by the r lines that follow, each with c characters. Each character in the grid is R, S, or P, indicating that it is occupied by Rocks, Scissors, or Papers respectively.
Output
For each test case, print the grid as it appears at the end of the nth day. Leave an empty line between the output for successive test cases.
Sample Input
2 3 3 1 RRR RSR RRR 3 4 2 RSPR SPRS PRSP
Sample Output
RRR RRR RRR RRRS RRSP RSPR
#include<iostream>
using namespace std;
int judge(char a,char b)
{
if(a==b)
return 0;
if(a=='P'&&b=='S' || a=='R'&&b=='P' || a=='S'&& b=='R')
return -1;
return 1;
}
int main()
{
char grid[105][105];
char res[105][105];
int cases;
int r,c,n;
// freopen("E:\\c++\\oj\\t.txt","rt",stdin);
cin>>cases;
while(cases--)
{
cin>>r>>c>>n;
for(int i=0;i<r;i++)
{
cin>>grid[i];
}
for(int i=0;i<n;i++)
{
for(int m=0;m<r;m++)
{
for(int n=0;n<c;n++)
{
if(m-1>=0)
{
if(judge(grid[m][n],grid[m-1][n])==-1)
{
res[m][n]=grid[m-1][n];
continue;
}
}
if(n-1>=0)
{
if(judge(grid[m][n],grid[m][n-1])==-1)
{
res[m][n]=grid[m][n-1];
continue;
}
}
if(m+1<r)
{
if(judge(grid[m][n],grid[m+1][n])==-1)
{
res[m][n]=grid[m+1][n];
continue;
}
}
if(n+1<c)
{
if(judge(grid[m][n],grid[m][n+1])==-1)
{
res[m][n]=grid[m][n+1];
continue;
}
}
res[m][n]=grid[m][n];
}
}
for(int i=0;i<r;i++)
{
for(int j=0;j<c;j++)
{
grid[i][j]=res[i][j];
}
}
}
for(int i=0;i<r;i++)
{
for(int j=0;j<c;j++)
{
cout<<res[i][j];
}
cout<<endl;
}
cout<<endl;
}
return 0;
}