POJ 3667 splay区间盘整运动

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12446 Accepted: 5363

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ XiN-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5


代码:

/* ***********************************************
Author :rabbit
Created Time :2014/11/1 12:57:54
File Name :4.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const int maxn=200200;
struct Node;
Node *null;
struct Node{
	Node *ch[2],*fa;
	int size;
	int lsum,rsum,msum,col,val;
	Node(){
		ch[0]=ch[1]=fa=null;
		col=0;
	}
	inline void setc(Node *p,int d){
		ch[d]=p;
		p->fa=this;
	}
	inline bool d(){
		return fa->ch[1]==this;
	}
	void clear(){
		size=1;
		ch[0]=ch[1]=fa=null;
		lsum=rsum=msum=val=1;
		col=-1;
	}
	inline void push_up(){
		if(this==null)return;
		size=ch[0]->size+ch[1]->size+1;
		lsum=ch[0]->lsum;
		rsum=ch[1]->rsum;
		msum=max(ch[0]->msum,ch[1]->msum);
		if(val){
			msum=max(msum,ch[0]->rsum+ch[1]->lsum+1);
			if(lsum==ch[0]->size)lsum+=ch[1]->lsum+1;
			if(rsum==ch[1]->size)rsum+=ch[0]->rsum+1;
		}
	}
	void update(int c){
		if(this==null)return;
		lsum=rsum=msum=c*size;
		val=col=c;
	}
	inline void push_down(){
		if(this==null)return;
		if(col!=-1){
			ch[0]->update(col);
			ch[1]->update(col);
			col=-1;
		}
	}
};
inline void rotate(Node *x){
	Node *f=x->fa,*ff=x->fa->fa;
	f->push_down();
	x->push_down();
	int c=x->d(),cc=f->d();
	f->setc(x->ch[!c],c);
	x->setc(f,!c);
	if(ff->ch[cc]==f)ff->setc(x,cc);
	else x->fa=ff;
	f->push_up();
}
inline void splay(Node *&root,Node *x,Node *goal){
	while(x->fa!=goal){
		if(x->fa->fa==goal)rotate(x);
		else{
			x->fa->fa->push_down();
			x->fa->push_down();
			x->push_down();
			bool f=x->fa->d();
			x->d()==f?

rotate(x->fa):rotate(x); rotate(x); } } x->push_up(); if(goal==null)root=x; } Node *get_kth(Node *r,int k){ Node *x=r; x->push_down(); while(x->ch[0]->size+1!=k){ if(k<x->ch[0]->size+1)x=x->ch[0]; else{ k-=x->ch[0]->size+1; x=x->ch[1]; } x->push_down(); } return x; } Node pool[maxn],*tail,*node[maxn],*root; void build(Node *&x,int l,int r,Node *fa){ if(l>r)return; int mid=(l+r)/2; x=tail++; x->clear(); x->fa=fa; node[mid]=x; build(x->ch[0],l,mid-1,x); build(x->ch[1],mid+1,r,x); x->push_up(); } void init(int n){ tail=pool; null=tail++; null->fa=null->ch[0]=null->ch[1]=null; null->size=0; null->val=null->lsum=null->rsum=null->msum=0;null->col=-1; Node *p=tail++; p->val=p->msum=p->rsum=p->lsum=0;p->col=-1; p->size=1;p->ch[0]=p->ch[1]=p->fa=null; root=p; p=tail++; p->val=p->msum=p->rsum=p->lsum=0;p->col=-1; p->size=1;p->ch[0]=p->ch[1]=p->fa=null; root->setc(p,1); build(root->ch[1]->ch[0],1,n,root->ch[1]); root->ch[1]->push_up(); root->push_up(); } void update(int l,int r,int c){ splay(root,get_kth(root,l),null); splay(root,get_kth(root,r+2),root); root->ch[1]->ch[0]->update(c); root->ch[1]->push_up(); root->push_up(); } int query(int l,int r){ splay(root,get_kth(root,l),null); splay(root,get_kth(root,r+2),root); return root->ch[1]->ch[0]->msum; } int find(Node *x,int k,int pos){ x->push_down(); //cout<<x->msum<<endl; if(x->ch[0]->msum>=k)return find(x->ch[0],k,pos); pos+=x->ch[0]->size; if(x->val&&x->ch[0]->rsum+x->ch[1]->lsum+1>=k)return pos-x->ch[0]->rsum; return find(x->ch[1],k,pos+1); } int main() { //freopen("data.in","r",stdin); //freopen("data.out","w",stdout); int n,m; while(~scanf("%d%d",&n,&m)){ init(n); //cout<<root->msum<<" "<<root->ch[0]->msum<<" "<<root->ch[1]->msum<<endl; while(m--){ int op,x,y; scanf("%d",&op); if(op==1){ scanf("%d",&x); if(root->msum<x){ puts("0");continue; } int k=find(root,x,0); printf("%d\n",k); update(k,k+x-1,0); } else{ scanf("%d%d",&x,&y); update(x,x+y-1,1); } } } return 0; } /* int main() { int n,m; while(cin>>n>>m) { init(n); while(m--){ int op,x,y,z; cin>>op; if(op==1){ cin>>x>>y>>z; update(x,y,z); } else{ cin>>x>>y; cout<<query(x,y)<<endl; } } } return 0; } */



版权声明:本文博主原创文章。博客,未经同意不得转载。

转载于:https://www.cnblogs.com/hrhguanli/p/4794678.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值