【贪心算法】POJ-3190 区间问题

一、题目

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample:

Here's a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

二、思路&心得

  • 贪心策略:先将所有数据按照开始时间start从小到大进行排序,然后以结束时间end为关键字维护一个最小优先队列。
  • 开始时先将排序后的第一个数据加入到优先队列中,然后依次扫描数据,若start大于队首元素的end值,则弹出队首元素,并将此时的数据加入到优先队列中,同时更新每个元素对应的stall[i]值。
  • 算法结束时,队列的大小即为所需要的stall个数。
  • 在定义结构体时,加入pos位置元素,以保存每个数据对应的原始位置,因为输出要求按照原始数据的顺序进行输出的。

三、代码

#include<cstdio>
#include<queue>
#include<algorithm>
#define MAX_SIZE 50005
using namespace std;

struct P {
    int start;
    int end;
    int pos;
} a[MAX_SIZE];

int N;

int stall[MAX_SIZE];

bool cmp(P a, P b) {
    return a.start < b.start;
}

bool operator > (P a, P b) {
    return a.end > b.end;
}

void solve() {
    priority_queue<P, vector<P>, greater<P> > que;
    for (int i = 0; i < N; i ++) {
        scanf("%d %d", &a[i].start, &a[i].end);
        a[i].pos = i;
    }
    sort(a, a + N, cmp);
    fill(stall, stall + N, 1);
    que.push(a[0]);
    for (int i = 1; i < N; i ++) {
        P temp = que.top();
        if (a[i].start > temp.end) {
            stall[a[i].pos] = stall[temp.pos];
            que.pop();
        } else {
            stall[a[i].pos] = que.size() + 1;
        }
        que.push(a[i]);
    }
    printf("%d\n", que.size());
    for (int i = 0; i < N; i ++) {
        printf("%d\n", stall[i]);
    }
}

int main() {
    scanf("%d", &N);
    solve();
    return 0;
} 

转载于:https://www.cnblogs.com/CSLaker/p/7290804.html

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值