1014 Stall Reservations

Problem Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:

  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time

Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5

1 10

2 4

3 6

5 8

4 7

Sample Output

4

1

2

3

2

4

Analyze

priority queue

Source Code

#include<iostream>
#include<algorithm>
#include<queue>
#define N 50010
using namespace std;
struct node{
    int st,ed;
    int num;
    friend bool operator < (node x,node y)//为优先队列设置优先级
    {
        if(x.ed==y.ed)
            return x.st<y.st;
        else
            return x.ed>y.ed;
    }
};
int cmp(node x,node y)
{
    if(x.st==y.st)
        return x.ed<y.ed;
    else
        return x.st<y.st;
}
int main()
{
    node cow[N];
    int pos[N];
    int ans=1;
    priority_queue<node> q;
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>cow[i].st>>cow[i].ed;
        cow[i].num=i;
    }
    sort(cow+1,cow+n+1,cmp);
    q.push(cow[1]);
    pos[1]=1;
    for(int i=2;i<=n;i++)
    {
        if( !q.empty() && q.top().ed<cow[i].st)//如果开始时间大于优先队列头部的结束值
        {
            pos[cow[i].num]=pos[q.top().num];//共用一个栏位
            q.pop();
        }
        else
        {
            ans++;//栏位数+1
            pos[cow[i].num]=ans;//记录栏位号
        }
        q.push(cow[i]);
    }
    cout<<ans<<endl;
    for(int i=1;i<=n;i++)
        cout<<pos[i]<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值