PAT 1030. Travel Plan

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

分析
这道题是Dijkstra算法的变体,在这里用的是邻接表建图,为了记录前驱节点,用集合pre去储存每个节点的前驱节点,当然为了最后的输出路径,出发点s的pre值为-1,输出路径倒着输出,集合dist储存每个节点到s的最短距离,Cost储存s到每个节点的花费,在Dijkstra算法中,如果dist[v2]<dist[v1]+distance时,要更新dist[v2],pre[v2],Cost[v2],如果dist[v2]==dist[v1]+distance但Cost[v2]<Cost[v1]+cost时,更新pre[v2],Cost[v2];

#include<iostream>
#include<vector>
using namespace std;
struct Node{
    int v,cost,distance;
};
int n,m,s,d;
vector<Node> G[500];
vector<int> dist(500,99999),Cost(500,99999),pre(500,-1),visited(500,0);
int findmin(){
    int t=-1,min=99999;
    for(int i=0;i<n;i++)
        if(dist[i]<min&&visited[i]==0){
            min=dist[i];
            t=i;
        }
    return t;
}
int main(){
    int c1,c2,cost,distance,v1,v2;
    cin>>n>>m>>s>>d;
    for(int i=0;i<m;i++){
        Node node1,node2;
        cin>>c1>>c2>>distance>>cost;
        node1.v=c1; node2.v=c2;
        node1.cost=node2.cost=cost; 
        node1.distance=node2.distance=distance;
        G[c1].push_back(node2);
        G[c2].push_back(node1);
    }
    dist[s]=0; Cost[s]=0; pre[s]=-1;
    while(1){
        v1=findmin();
        if(v1==-1) break; 
        visited[v1]=1;
        for(int i=0;i<G[v1].size();i++){
            v2=G[v1][i].v;
            if(visited[v2]!=1){
                if(dist[v1]+G[v1][i].distance<dist[v2]){
                   dist[v2]=dist[v1]+G[v1][i].distance;
                   Cost[v2]=Cost[v1]+G[v1][i].cost;
                   pre[v2]=v1;
                }else if(dist[v1]+G[v1][i].distance==dist[v2]&&Cost[v2]>Cost[v1]+G[v1][i].cost){
                   Cost[v2]=Cost[v1]+G[v1][i].cost; 
                   pre[v2]=v1;
                }
            }
        }
    }
    vector<int> vi; int temp=d;
    while(temp!=-1){
        vi.push_back(temp);
        temp=pre[temp];
    }
    for(int i=vi.size()-1;i>=0;i--)
    cout<<vi[i]<<" ";
    cout<<dist[d]<<" "<<Cost[d];
    return 0;
}

转载于:https://www.cnblogs.com/A-Little-Nut/p/8289150.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值