hdu 6090 Rikka with Graph

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 425    Accepted Submission(s): 270

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph  G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G (wG) as ni=1nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).
 
Input
The first line contains a number  t(1t10), the number of the testcases. 

For each testcase, the first line contains two numbers n,m(1n106,1m1012).
 
Output
For each testcase, print a single line with a single number -- the answer.
 
Sample Input
1
4 5
 
Sample Output
14
 
Source
Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6095  6094  6093  6092  6091 
 
题目大意:
给定n个点,m条边,让你安排点和边构成一个无向图。dis(i,j),表示i到j最小的边数,如果无法到达,dis(i,j)为n,问每个点到其他所有的点的dis之和。
 
题解:
模拟几组数据:
n=4,m=6,----->res=12
n=4,m=5,----->res=14
n=4,m=4,----->res=16
n=4,m=3,----->res=18  
,//到此为止是不是可以找到规律,当 n-1 <= m <= (n-1)*n/2 时,res= n*(n-1)+(n*(n-1)/2-m)*2,当 m > (n-1)**n/2 时,答案还是 n*(n-1)
n=4,m=2,----->res=32
n=4,m=1,----->res=42  
//  当 m < n-1,即所有点不能连成一块,则分成两部分来算,一部分是连在一起的(m+1)个点,还有一部分是 ( n- (m+1) )个点
一.  连在一起的点可以套用前面的公式算出是 2*m*m
二.  没有连在一起,答案计算又可以分成两部分,一部分是和那些连在一起的点的长度,(n-m-1)*( m+1 )* n * 2,一部分是孤立的点相互连,(n-m-1)*(n-m-2)*n
       这部分总结的答案是(n-m-1)* ( m+1 ) * n * 2+( n-m-1 ) * ( n-m-2 ) * n
最后答案是(n-m-1)* ( m+1 ) * n * 2  +  ( n-m-1 ) * ( n-m-2 ) * n + 2 * m * m
 
 
官方题解:

1006 Rikka with Graph

考虑贪心地一条一条边添加进去。

当 mn1 时,我们需要最小化距离为 n的点对数,所以肯定是连出一个大小为 m+1 的联通块,剩下的点都是孤立点。在这个联通块中,为了最小化内部的距离和,肯定是连成一个菊花的形状,即一个点和剩下所有点直接相邻。

当 m > n-1 时,肯定先用最开始 n-1 条边连成一个菊花,这时任意两点之间距离的最大值是 2。因此剩下的每一条边唯一的作用就是将一对点的距离缩减为 1。

这样我们就能知道了最终图的形状了,稍加计算就能得到答案。要注意 有可能大于   n(n-1)/2​​

#include <iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
using namespace std;

int T;
long long n,m;


int main()
{
    scanf("%d",&T);
    for(;T>0;T--)
    {
        scanf("%lld%lld",&n,&m);
        if (m>=n-1)
        {
            if (m<=n*(n-1)/2) printf("%lld\n",n*(n-1)+(n*(n-1)/2-m)*2);
              else printf("%lld\n",n*(n-1));
        }
          else
          {
              printf("%lld\n",2*m*m+(n-m-1)*(m+1)*2*n+(n-m-1)*(n-m-2)*n);
          }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/stepping/p/7324182.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值