HDU 6090 Rikka with Graph(贪心)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 636


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) ( dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G ( wG) as ni=1nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).
 

Input
The first line contains a number t(1t10), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n106,1m1012).
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
 
 
1 4 5
 

Sample Output
 
 
14
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6297  6296  6295  6294  6293 
#include<algorithm>
#include<iostream>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define maxn 100
#define UB (maxn*64)
#define ll __int64
#define INF 10000000
using namespace std;
/*
题目大意:给定n个点,要求加上m条边后,
所定义的函数值最小,其函数是每个点到每个点的最短距离之和。

首先观察恰好连通的情况也就是树的情况,
那么一定是星型最优,具体证明也好证,
当然。。。。时间上肯定不允许那么严格的证明了,感觉很重要。
在星型的基础上,每连一条边,总值少2。

下面就是对m分类讨论了,是连通的,还是多余的(完全图),还是不连通的(不连通这块我每搞懂,答案看网上的。。。。)
*/
long long  n,m;
int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>n>>m;
        long long tmp=(n-1)*(n-1);
        if(2*m>n*(n-1)) cout<<n*(n-1)<<endl;
        else if(m<n-1) cout<<2*m*m+n*(n+m)*(n-m-1)<<endl;///
        else cout<<2*(tmp-m+n-1)<<endl;
    }
    return 0;
}



 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值