HDU 5974 A Simple Math Problem(数论+结论)

Problem Description


Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b

 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input

6 8
798 10780

 

Sample Output

No Solution
308 490

 

题意:给出a和b,使x+y=a,lcm(x,y)=b

 

题解:我们来推一波公式

x+y=a

x*y/gcd(x,y)=b

上下都除个gcd(x,y)

x/gcd(x,y)+y/gcd(x,y)=a/gcd(x,y)

x/gcd(x,y)*y/gcd(x,y)=b/gcd(x,y)

令x/gcd(x,y)为x1,y/gcd(x,y)为y1

显然x1,y1互质

所以

gcd(x1,x1+y1)=1

gcd(y1,x1+y1)=1

gcd(x1*y1,x1+y1)=1

 

b/gcd(x,y)与a/gcd(x,y)互质

所以gcd(x,y)=gcd(a,b)

这样就可以推出b/gcd(x,y)=b/gcd(a,b)与a/gcd(x,y)=a/gcd(a,b);

我们可以开局就求出上面的东西

问题就变成了求x+y=n,xy=m

显然小学数学推一波就稳了

 

代码如下:

 

#include<cmath>
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#define lson root<<1
#define rson root<<1|1
using namespace std;

long long a,b;

int main()
{
    while(~scanf("%lld%lld",&a,&b))
    {
        long long tmp=__gcd(a,b);
        a/=tmp;
        b/=tmp;
        if(a*a-4*b<0) {puts("No Solution"); continue;}
        long long det=(long long) (sqrt(a*a-4*b));
        if(det*det!=a*a-4*b) {puts("No Solution"); continue;}
        long long x=det+a;
        long long y=a-det;
        if(x&1||y&1) {puts("No Solution"); continue;}
        x>>=1;
        y>>=1;
        if(x>y)swap(x,y);
        printf("%lld %lld\n",x*tmp,y*tmp);
    }
}

 

转载于:https://www.cnblogs.com/stxy-ferryman/p/9642571.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值