A Simple Math Problem (HDU - 5974)

点击打开原题链接

Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490

这题算是到数学水题,然而自己嘿嘿嘿嘿没做出来,很尴尬。

思路:
   

假设gcd(x,y)=l

i*l+j*l==a

i*j*l==b

因为i和j此时互质

所以 i+j 和 i*j 也互质

所以gcd(a,b)==l==gcd(x,y)

联立

i+j=a/l

i*j=b/l

连立解这个方程组。

上代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
long long gcd(long long x, long long y)
{
	return y==0 ? x : gcd(y, x%y);
}
int main()
{
	long long a,b,x,y,i,j,l;
	
	while(scanf("%I64d %I64d", &a, &b)!=EOF)
	{
		l = gcd(max(a,b),min(a,b));
		long long a_l = a/l;
		long long b_l = b/l;
		long long daierta = a_l*a_l - 4 * b_l;
		if(daierta<0)
		{
			printf("No Solution\n");
			continue;
		}
		long long gen = sqrt(daierta*1.0);
		if(gen*gen != daierta)
		{
			printf("No Solution\n");
			continue;
		}
		
		i = (a_l - gen) / 2;
		
		j = (a_l + gen) / 2;
		if(i*2 != (a_l - gen) || j*2 != (a_l + gen) || i<=0 || j<=0)
		{
			printf("No Solution\n");
			continue;
		}
		printf("%I64d %I64d\n",min(i,j)*l, max(i,j)*l);
		
	}
    return 0;	
} 
水波。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值