[BZOJ1294][SCOI2009]围豆豆Bean

[BZOJ1294][SCOI2009]围豆豆Bean

试题描述

OwO

输入

第一行两个整数 \(N\)\(M\),为矩阵的边长。 第二行一个整数 \(D\),为豆子的总个数。 第三行包含 \(D\) 个整数 \(V_1\)\(V_D\),分别为每颗豆子的分值。 接着 \(N\) 行有一个 \(N \times M\) 的字符矩阵来描述游戏矩阵状态,0 表示空格,# 表示障碍物。而数字 19 分别表示对应编号的豆子。

输出

仅包含一个整数,为最高可能获得的分值。

输入示例
3 8
3
30 -100 30
00000000
010203#0
00000000
输出示例
38
数据规模及约定

\(50\texttt{%}\) 的数据满足 \(1 \le D \le 3\)

\(100\texttt{%}\) 的数据满足 \(1 \le D \le 9\)\(1 \le N, M \le 10\)\(-10000 \le V_i \le 10000\)

题解

传说中的射线法。判断一个点是否在一个任意多边形内部可以从这个点向任意一个方向引一条射线,若多边形的边交它奇数次则该点在多边形内,否则不在。

这道题对于每个豆豆我们向右水平引一条射线,然后状压,在经过射线的时候改变一些豆子是否在内部的状态,枚举起点 BFS 即可。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;
#define rep(i, s, t) for(int i = (s); i <= (t); i++)
#define dwn(i, s, t) for(int i = (s); i >= (t); i--)

int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == '-') f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - '0'; c = getchar(); }
    return x * f;
}

#define maxn 15
#define maxs 512

int n, m, D, val[maxn], beans[maxn][maxn], sum[maxs];
char Map[maxn][maxn];
struct Node {
    int x, y, S; bool ud, from;
    Node() {}
    Node(int _1, int _2, int _3, bool _4, bool _5): x(_1), y(_2), S(_3), ud(_4), from(_5) {}
} Q[maxn*maxn*maxs<<2];
int step[maxn][maxn][maxs][2][2], ans, dx[4] = {-1, 1, 0, 0}, dy[4] = {0, 0, -1, 1};
bool iszero(int x, int y) { return 1 <= x && x <= n && 1 <= y && y <= m && Map[x][y] == '0'; }
void solve(int sx, int sy) {
    memset(step, -1, sizeof(step));
    int hd = 0, tl = 0;
    if(beans[sx][sy]) {
        if(sx > 1) step[sx][sy][0][0][0] = 0, Q[++tl] = Node(sx, sy, 0, 0, 0);
        if(sx < n) step[sx][sy][0][1][1] = 0, Q[++tl] = Node(sx, sy, 0, 1, 1);
    }
    else step[sx][sy][0][0][0] = 0, Q[++tl] = Node(sx, sy, 0, 0, 0);
    while(hd < tl) {
        Node u = Q[++hd];
        rep(i, 0, 3) {
            Node v(u.x + dx[i], u.y + dy[i], u.S, u.ud, u.from);
            if(iszero(v.x, v.y)) {
                if(dx[i]) {
                    if(beans[u.x][u.y] && ((dx[i] == -1 && u.ud) || (dx[i] == 1 && !u.ud)))
                        v.S ^= beans[u.x][u.y];
                    if(beans[v.x][v.y]) v.ud = dx[i] == -1;
                    else v.ud = 0;
                }
                if(step[v.x][v.y][v.S][v.ud][v.from] >= 0) continue;
                step[v.x][v.y][v.S][v.ud][v.from] = step[u.x][u.y][u.S][u.ud][u.from] + 1;
                Q[++tl] = v;
            }
        }
    }
    rep(S, 0, (1 << D) - 1) {
        if(beans[sx][sy]) {
            if(step[sx][sy][0][0][0] >= 0) {
                if(step[sx-1][sy][S][0][0] >= 0) ans = max(ans, sum[S^beans[sx-1][sy]] - step[sx-1][sy][S][0][0] - 1);
                if(step[sx-1][sy][S][1][0] >= 0) ans = max(ans, sum[S] - step[sx-1][sy][S][1][0] - 1);
            }
            if(step[sx][sy][0][1][1] >= 0) {
                if(step[sx+1][sy][S][0][1] >= 0) ans = max(ans, sum[S] - step[sx+1][sy][S][0][1] - 1);
                if(step[sx+1][sy][S][1][1] >= 0) ans = max(ans, sum[S^beans[sx+1][sy]] - step[sx+1][sy][S][1][1] - 1);
            }
        }
        else {
            if(step[sx][sy][S][0][0] >= 0) ans = max(ans, sum[S] - step[sx][sy][S][0][0]);
            if(step[sx][sy][S][1][0] >= 0) ans = max(ans, sum[S] - step[sx][sy][S][1][0]);
        }
    }
    return ;
}

int main() {
    n = read(); m = read(); D = read();
    rep(i, 1, D) val[i] = read();
    rep(i, 1, n) scanf("%s", Map[i] + 1);
    
    rep(i, 1, n) rep(j, 1, m)
        if('1' <= Map[i][j] && Map[i][j] <= '9')
            rep(k, j, m) beans[i][k] |= (1 << Map[i][j] - '1');
    
    rep(S, 0, (1 << D) - 1)
        rep(j, 0, D - 1) if(S >> j & 1) sum[S] += val[j+1];
    rep(i, 1, n) rep(j, 1, m) if(Map[i][j] == '0') solve(i, j);
    
    printf("%d\n", ans);
    
    return 0;
}

一个小技巧:每个豆子可以看成是它所在的方格的上边界的中点,从这个中点向右引射线,这样会好做很多。(想一想,为什么这样是对的)

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;
#define rep(i, s, t) for(int i = (s); i <= (t); i++)
#define dwn(i, s, t) for(int i = (s); i >= (t); i--)

int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == '-') f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - '0'; c = getchar(); }
    return x * f;
}

#define maxn 15
#define maxs 512

int n, m, D, val[maxn], beans[maxn][maxn];
char Map[maxn][maxn];

struct Node {
    int x, y, S;
    Node() {}
    Node(int _1, int _2, int _3): x(_1), y(_2), S(_3) {}
} Q[maxn*maxn*maxs];
int step[maxn][maxn][maxs], ans, dx[4] = {-1, 1, 0, 0}, dy[4] = {0, 0, -1, 1};
bool iszero(int x, int y) { return 1 <= x && x <= n && 1 <= y && y <= m && Map[x][y] == '0'; }
void solve(int sx, int sy) {
    memset(step, -1, sizeof(step));
    step[sx][sy][0] = 0;
    int hd = 0, tl = 0;
    Q[++tl] = Node(sx, sy, 0);
    while(hd < tl) {
        Node u = Q[++hd];
        rep(i, 0, 3) {
            Node v(u.x + dx[i], u.y + dy[i], u.S);
            if(iszero(v.x, v.y)) {
                if(beans[v.x][v.y] && dx[i] == 1) v.S ^= beans[v.x][v.y];
                if(beans[u.x][u.y] && dx[i] == -1) v.S ^= beans[u.x][u.y];
                if(step[v.x][v.y][v.S] >= 0) continue;
                step[v.x][v.y][v.S] = step[u.x][u.y][u.S] + 1;
                Q[++tl] = v;
            }
        }
    }
    rep(S, 0, (1 << D) - 1) {
        int sum = 0;
        rep(i, 0, D - 1) if(S >> i & 1) sum += val[i+1];
        if(step[sx][sy][S] >= 0) ans = max(ans, sum - step[sx][sy][S]);
    }
    return ;
}

int main() {
    n = read(); m = read(); D = read();
    rep(i, 1, D) val[i] = read();
    rep(i, 1, n) scanf("%s", Map[i] + 1);
    
    rep(i, 1, n) rep(j, 1, m)
        if('1' <= Map[i][j] && Map[i][j] <= '9')
            rep(k, j, m) beans[i][k] |= (1 << Map[i][j] - '1');
    rep(i, 1, n) rep(j, 1, m) if(Map[i][j] == '0') solve(i, j);
    
    printf("%d\n", ans);
    
    return 0;
}

转载于:https://www.cnblogs.com/xiao-ju-ruo-xjr/p/7718520.html

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值