HDU1556 Color the ball(差分数组)题解

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25164    Accepted Submission(s): 12226


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
 
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
 
  
1 1 1 3 2 1


思路:

昨天刚学的,没时间写,今天写出来,感觉很简单方便,可以看这个连接,讲的比较详细

Code:


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<map>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=100005;
int b[N]; 
int main(){
	int n,l,r;
	int sum;
	while(~scanf("%d",&n) && n){
		memset(b,0,sizeof(b));
		for(int j=0;j<n;j++){
			scanf("%d%d",&l,&r);
			b[l]++;
			b[r+1]--;
		}
		sum=0;
		for(int i=1;i<=n;i++){
			if(i!=1) printf(" ");
			sum+=b[i];
			printf("%d",sum);
		}
		printf("\n");
	}
	return 0;	
}

转载于:https://www.cnblogs.com/KirinSB/p/9409127.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值