模拟退火 Buried memory

Each person had do something foolish along with his or her growth.But,when he or she did this that time,they could not predict that this thing is a mistake and they will want this thing would rather not happened.
The world king Sconbin is not the exception.One day,Sconbin was sleeping,then swakened by one nightmare.It turned out that his love letters to Dufein were made public in his dream.These foolish letters might ruin his throne.Sconbin decided to destroy the letters by the military exercises's opportunity.The missile is the best weapon.Considered the execution of the missile,Sconbin chose to use one missile with the minimum destruction.
Sconbin had writen N letters to Dufein, she buried these letters on different places.Sconbin got the places by difficult,he wants to know where is the best place launch the missile,and the smallest radius of the burst area. Let's help Sconbin to get the award.

InputThere are many test cases.Each case consists of a positive integer N(N<500,^V^,our great king might be a considerate lover) on a line followed by N lines giving the coordinates of N letters.Each coordinates have two numbers,x coordinate and y coordinate.N=0 is the end of the input file.OutputFor each case,there should be a single line in the output,containing three numbers,the first and second are x and y coordinates of the missile to launch,the third is the smallest radius the missile need to destroy all N letters.All output numbers are rounded to the second digit after the decimal point.
Sample Input

3
1.00 1.00
2.00 2.00
3.00 3.00
0

Sample Output

2.00 2.00 1.41

思路:枚举圆心 找最长半径 看能否 朝着这个方向继续更新答案


code:
//
#include<bits/stdc++.h>
using namespace std;
int n;
#define maxnn  1000
double x[maxnn],y[maxnn];
double delta=0.98;
double T=1;
double eps=1e-9;
double dist(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void init()
{
    memset(x,0,sizeof(x));
    memset(y,0,sizeof(y));
}
void tui()
{
    double t=100;
    double ans=100000000;
    double sx=x[1];
    double sy=y[1];
    double nowx=0;
    double nowy=0;
    while(t>eps)
    {
            double now=0;
            double nowx=sx;
            double nowy=sy;
            int pal=0;
            for(int i=1;i<=n;i++)
            {
                if(now<dist(x[i],y[i],nowx,nowy))
                {
                    now=max(now,dist(x[i],y[i],nowx,nowy));
                    pal=i;
                }
            }
            if(now<ans)
            {
                ans=now;
            }
            sx+=t*(x[pal]-nowx)/(dist(nowx,nowy,x[pal],y[pal]));
            sy+=t*(y[pal]-nowy)/(dist(nowx,nowy,x[pal],y[pal]));  //朝着一个方向移动
        t*=delta;
    }
    printf("%.2f %.2f %.2f\n",sx,sy,ans);
}
int main()
{
    while(cin>>n)
    {
        if(n==0)
        return 0;
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&x[i],&y[i]);    
        } 
        tui();
    }
 } 

 

转载于:https://www.cnblogs.com/OIEREDSION/p/11290434.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值