UVa 10943 - How do you add?

Description

Larry is very bad at math - he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. They're now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you!
It's a very simple problem - given a number N, how many ways can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15
...
18+2
19+1
20+0

Input

Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0's.

Output

Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.

Sample Input

20 2
20 2
0 0

Sample Output

21
21

Resume

将N分解成K个非负整数之和的方案数。

Analysis

  • 思路一:
    高中组合数问题,通过隔板法可得答案为 \({C_{n+k-1}}^n\) 种。
  • 思路二:
    动态规划,转移方程为\[d[i][j] = d[i-1][j] + d[i][j-1] \]其中 \(d[i][j]\) 表示将\(i\)拆分成\(j\)个数的方案总数。

Code(Measure One)

//
//Target: UVa 10943 - How do you add?
//@Author: Pisceskkk
//Date: 2019-2-16
//

#include<cstdio>
#define N 220
#define mod 1000000
#define ll long long
using namespace std;

int n,k,f[N][N];
int dfs(int a,int b){
    if(a < b)return 0;
    if(b == 0)return 1;
    if(a == 0)return 1;
    if(f[a][b])return f[a][b];
    return f[a][b] = (dfs(a-1,b-1)+dfs(a-1,b))%mod;
}
int main(){
    while(1){
        scanf("%d %d",&n,&k);
        if(!n && !k){
            break;
        }
        printf("%d\n",dfs(n+k-1,n));
    }
    return 0;
}

转载于:https://www.cnblogs.com/pisceskkk/p/10421427.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值