HDU1757 A Simple Math Problem 矩阵快速幂

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4331    Accepted Submission(s): 2603

Problem Description
Lele now is thinking about a simple function f(x).
If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .
Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 
Output
For each case, output f(k) % m in one line.
 
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
 
Sample Output
45
104
 
题意:给出递推公式求第n项
题解:矩阵快速幂,注意初始矩阵为[9,8,7,6,5,4,3,2,1,0]

 

#include<bits/stdc++.h>
#define N 10
#define mes(x) memset(x, 0, sizeof(x));
#define ll __int64
long long mod = 1e9+7;
const int MAX = 0x7ffffff;
using namespace std;
struct mat{
    ll a[N][N];
    mat(){
        memset(a, 0, sizeof(a));
    }
    mat operator *(mat b){
        mat c;
        for(int i=0;i<N;i++)
            for(int j=0;j<N;j++)
            for(int k=0;k<N;k++)
            c.a[i][j] = (c.a[i][j] + a[i][k]*b.a[k][j])%mod;
        return c;
    }
};
mat f(mat x,ll m){
    mat t;
    for(int i=0;i<N;i++)
        t.a[i][i] = 1;
    while(m){
        if(m&1) t = t*x;
        x = x*x;
        m >>= 1;
    }
    return t;
}
int main()
{
    ll k, i;
    while(~scanf("%I64d%I64d", &k, &mod)){
        if(k<10){
            printf("%I64d\n", k);
            continue;
        }
        mat A, s;
        for(i=0;i<10;i++)
            s.a[0][i] = 9-i;
        for(i=0;i<10;i++)
            scanf("%I64d", &A.a[i][0]);
        for(i=0;i<9;i++)
            A.a[i][i+1] = 1;    
        s = s*f(A, k-9);
        printf("%I64d\n", s.a[0][0]);
    }
    
    return 0;
}

 

转载于:https://www.cnblogs.com/Noevon/p/6111373.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值