HDU1009老鼠的旅行 (贪心算法)

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62898    Accepted Submission(s): 21231


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 

 

Author
CHEN, Yue
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1050  1051  2037  1052 
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
using namespace std;
struct sa
{
    int a,b;
    double c;
}data[3005];
bool cmp(sa x,sa y)
{
    return x.c>y.c;
}
int main()
{
    int i,j,m,n;
    double sum;
    while (cin>>m>>n&&m!=-1&&n!=-1)
    {
        sum=0;
        for (i=0;i<n;i++)
        {
            cin>>data[i].a>>data[i].b;
            data[i].c=(double)data[i].a/(double)data[i].b;
        }
        sort(data,data+n,cmp);
        //for (i=0;i<n;i++)
        //cout<<data[i].a<<" "<<data[i].b<<" "<<data[i].c<<endl;
        for (i=0;i<n;i++)
        {
            if (m>=data[i].b)
            {
                m-=data[i].b;
                sum+=data[i].a;
            }
            else if (m<data[i].b&&m>0)
            {
                sum+=data[i].c*(double)m;
                m=0;
            }
            else
            break;
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Ritchie/p/5425318.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值