浙江大学PAT上机题解析之1050. String Subtraction (20)

1050. String Subtraction (20)

时间限制 
10 ms
内存限制 
32000 kB
代码长度限制 
16000 B
判题程序   
Standard

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1.  Your task is simply to calculate S1 - S2 for any given strings.  However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case.  Each case consists of two lines which gives S1 and S2, respectively.  The string lengths of both strings are no more than 104.  It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line. 

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
 
  
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>

using namespace std;

string str1;
string str2;

string::iterator it1,it2;

bool compare(char ch)
{
	for (it2=str2.begin();it2!=str2.end();it2++)
		if (ch == *it2)
		return true;
return false;
}


int main()
{

 getline(cin,str1);
 getline(cin,str2);

 sort(str2.begin(),str2.end());

 str2.erase(unique(str2.begin(),str2.end()),str2.end());

str1.resize(remove_if(str1.begin(),str1.end(),compare) - str1.begin());

 cout<<str1<<endl;

  //system("pause");
	return 0;
}

 
 

转载于:https://www.cnblogs.com/ainima/p/6331277.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值