hdu 5884 Sort 队列+多叉哈夫曼树

Sort

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Recently, Bob has just learnt a naive sorting algorithm: merge sort. Now, Bob receives a task from Alice.
Alice will give Bob  N sorted sequences, and the i-th sequence includes ai elements. Bob need to merge all of these sequences. He can write a program, which can merge no more than k sequences in one time. The cost of a merging operation is the sum of the length of these sequences. Unfortunately, Alice allows this program to use no more than T cost. So Bob wants to know the smallest k to make the program complete in time.
 

 

Input
The first line of input contains an integer  t0, the number of test cases. t0 test cases follow.
For each test case, the first line consists two integers N (2N100000) and T (Ni=1ai<T<231).
In the next line there are N integers a1,a2,a3,...,aN(i,0ai1000).
 

 

Output
For each test cases, output the smallest  k.
 

 

Sample Input
1 5 25 1 2 3 4 5
 

 

Sample Output
3
 

 

Source
 

由于多叉哈夫曼最后可能不能得到k个再合并成一个,可以先将多的部分取余,或者加0;

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
const int N=1e5+10,M=1e6+10,inf=1e9+10,mod=1e9+7;
const ll INF=1e18+10;
ll n,m;
ll a[N];
int check(int x)
{
    queue<ll>q;
    queue<ll>d;
    int yy=(n-1)%(x-1);
    if(yy!=0)
    {
        for(int i=0;i<x-1-yy;i++)
        q.push(0);
    }
    for(ll i=1;i<=n;i++)
    q.push(a[i]);
    ll ans=0;
    while(!q.empty()||!d.empty())
    {
        ll sum=0;
        for(int i=0;i<x;i++)
        {
            if(q.empty()&&d.empty())
                break;
            if(q.empty())
            {
                sum+=d.front();
                d.pop();
            }
            else if(d.empty())
            {
                sum+=q.front();
                q.pop();
            }
            else
            {
                int u=q.front();
                int v=d.front();
                if(u<v)
                {
                    sum+=u;
                    q.pop();
                }
                else
                {
                    sum+=v;
                    d.pop();
                }
            }
        }
        ans+=sum;
        if(q.empty()&&d.empty())
        break;
        d.push(sum);
    }
    if(ans>m)
        return 0;
    return 1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&n,&m);
        for(ll i=1;i<=n;i++)
        scanf("%lld",&a[i]);
        sort(a+1,a+n+1);
        int st=2,en=n;
        while(st<en)
        {
            int mid=(st+en)/2;
            if(check(mid))
            en=mid;
            else
            st=mid+1;
        }
        printf("%d\n",st);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/5879452.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值