Phone List

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7094    Accepted Submission(s): 2434


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
 
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
 
  
NO YES
 
#include <iostream>
#include <string>
using namespace std;
int flag;
struct dictree
{
	dictree *child[10];
	bool final;
	dictree()
	{
		memset(child,0,sizeof(child));
		final=false;//标记是否为终止节点
	}
};
dictree *root;/*注意的是,输入的字符序列并不是字典序的,所以可能出现前缀先插入树,和前缀后插入树两种情况,要分开判定哦,呵呵*/
void insert(string source)
{
	dictree *current,*newnode;
	int len = source.length();
	if(!len)
		return ;
	current = root;
	for(int i=0;i<len;i++)
	{
		if(current->child[source[i]-'0']!=0)
		{
			if(i==len-1)//判定的是先输入了一个长长的字符串,后输入了它的某个前缀的情况
				flag--;
			current =current->child[source[i]-'0'];
		}
		else 
		{
			if(current->final==true)//判定的是先输入了某个前缀,后输入了以它为前缀的字符串的情况
			{
				flag--;
				current->final=false;
			}
			newnode = new dictree();
			current->child[source[i]-'0']=newnode;
			current=newnode;
			if(i==len-1)
			current->final=true;
		}
	}
}
void del(dictree *root)//注意,每次都要释放掉这课树,不然会MLE。递归销毁树的技巧,学习了。。
{
	if(root==0)
		return ;//貌似没用,这个判断。。
	for(int i=0;i<10;i++)
	{
		if(root->child[i]!=0)
			del(root->child[i]);
	}
	delete root;
	return ;
}
int main()
{
	string temp;
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		root=new dictree();
		scanf("%d",&n);
		flag=n;
		for(int i=0;i<n;i++)
		{
			cin>>temp;
			insert(temp);
		}
		if(flag!=n)
			printf("NO\n");
		else
			printf("YES\n");
		del(root);
	}
	return 0;
}/*算是我的第一道字典树的题目吧。虽然模板起了很大作用,不过我慢慢理解了,就是我的了,不是么。学习本身就是一个不断模仿的过程*/


 
 

转载于:https://www.cnblogs.com/unclejelly/p/4082145.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值