POJ - 3630 Phone List(字典树水题)

Phone List

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题意:给定 n 个电话号码,若存在一个电话号码是另一个电话号码的前缀,输出 NO,否则输出 YES

思路:建好字典树,依次遍历每个电话号码,若路径上存在一个节点 Color == 1,或 这个电话号码出现了 2 次,输出NO

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 1e5 + 10;
int trie[maxn][15];
int color[maxn];
int k = 1;

void add(char *s){
    int len = strlen(s);
    int p = 0;
    for(int i = 0;i < len;++ i){
        int c = s[i] - '0';
        if(!trie[p][c])
            trie[p][c] = k ++;
        p = trie[p][c];
    }
    ++ color[p];
}

bool check(char *s){
    int len = strlen(s);
    int p = 0;
    for(int i = 0;i < len;++ i){
        int c = s[i] - '0';
        if(color[p])
            return true;
        p = trie[p][c];
    }
    return color[p] > 1;
}

char s[maxn][15];

int main() {
    int t; scanf("%d",&t);
    while(t --){
        clr(trie,0);
        clr(color,0);
        k = 1;
        int n; scanf("%d",&n);
        for(int i = 0;i < n;++ i){
            scanf("%s",s[i]);
            add(s[i]);
        }
        bool flag = false;
        for(int i = 0;i < n;++ i){
            flag = check(s[i]);
            if(flag) break;
        }
        printf("%s\n",flag ? "NO" : "YES");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值