ACM-ICPC 2018 焦作赛区网络预赛 G. Give Candies

There are NN children in kindergarten. Miss Li bought them NN candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1...N)(1...N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.

Input

The first line contains an integer TT, the number of test case.

The next TT lines, each contains an integer NN.

1 \le T \le 1001≤T≤100

1 \le N \le 10^{100000}1≤N≤10100000

Output

For each test case output the number of possible results (mod 1000000007).

样例输入复制

1
4

样例输出复制

8

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

通过打表可知,答案是2^n-1 ,但是n又太大,直接计算会超时。所以这里就需要用到欧拉函数了。话不多说上代码:

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
char a[1005][1005];
int main()
{
    int n;
    a[0][0] = '1';
    int before = 1;
    for(int i = 1;i <= 100; ++i)
    {
        int k = 0;
        int mod = 0;
        for(int j = 0;j < before;++j)
        {
            a[i][k++] = ((a[i - 1][j] - '0') * 2 + mod) % 10+48;
            mod = (((a[i - 1][j] - '0') * 2) + mod) / 10;
        }
        if(mod)
            a[i][k++] = mod + 48;
        before=k;
    }
    while(cin>>n)
    {
        int len=strlen(a[n]);
        for(int i=len-1;i>=0;--i)
            cout<<a[n][i];
        cout<<endl;
    }
}

 

转载于:https://www.cnblogs.com/Romantic-Chopin/p/10253087.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值