HDU acm 1003 Max Sum || 动态规划求最大子序列和详解

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164592    Accepted Submission(s): 38540

 Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4
 
Case 2:
7 1 6
#include<iostream>
using namespace std;
int main()
{
    int T;//T为输入例子的个数 
    cin>>T;
    for(int i=1;i<=T;i++)
    {
        int N;//N为每个例子中数字的个数 
        cin>>N;
        int s=0,start1=1,start2,end,maxsum=INT_MIN;
        //s为以目前为止的点作为结束的一类中,最大的和 ;
//start1为以目前为止的点作为结束的一类中最大和序列的起点坐标
//start2为最终确定的最大和序列中的起点坐标
//end为最终确定的最大和序列结束点的坐标
//maxsum为最终确定的最大和 for(int j=1;j<=N;j++) { int a; cin>>a; if(s<0) { s=a; start1=j; } else { s+=a; } if(s>maxsum) { maxsum=s; start2=start1; end=j; } } cout<<"Case "<<i<<":"<<endl; cout<<maxsum<<" "<<start2<<" "<<end<<endl; if(i<T) cout<<endl; } }

具体原理可参考http://alorry.blog.163.com/blog/static/6472570820123801223397/

 

 

转载于:https://www.cnblogs.com/denghui666/p/7157457.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值